aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-2.6.23/arm-hwcap-add-new-entries.patch21
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb5
2 files changed, 24 insertions, 2 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.23/arm-hwcap-add-new-entries.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.23/arm-hwcap-add-new-entries.patch
new file mode 100644
index 0000000000..934db516b1
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers-2.6.23/arm-hwcap-add-new-entries.patch
@@ -0,0 +1,21 @@
+---
+ include/asm-arm/hwcap.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- linux-2.6.23.orig/include/asm-arm/hwcap.h
++++ linux-2.6.23/include/asm-arm/hwcap.h
+@@ -13,10 +13,14 @@
+ #define HWCAP_VFP 64
+ #define HWCAP_EDSP 128
+ #define HWCAP_JAVA 256
+ #define HWCAP_IWMMXT 512
+ #define HWCAP_CRUNCH 1024
++#define HWCAP_THUMBEE 2048
++#define HWCAP_NEON 4096
++#define HWCAP_VFPv3 8192
++#define HWCAP_VFPv3D16 16384
+
+ #if defined(__KERNEL__) && !defined(__ASSEMBLY__)
+ /*
+ * This yields a mask that user programs can use to figure out what
+ * instruction set this cpu supports.
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb
index 95152f1b22..b4766bc295 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb
@@ -2,11 +2,12 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r4"
+PR = "r6"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://procinfo.h \
- file://unifdef.patch;patch=1"
+ file://unifdef.patch;patch=1 \
+ file://arm-hwcap-add-new-entries.patch;patch=1"
S = "${WORKDIR}/linux-${PV}"