aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/jacl/jacl-native_1.4.1.bb4
-rw-r--r--recipes/jacl/jacl_1.4.1.bb20
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/jacl/jacl-native_1.4.1.bb b/recipes/jacl/jacl-native_1.4.1.bb
new file mode 100644
index 0000000000..b0a0638dde
--- /dev/null
+++ b/recipes/jacl/jacl-native_1.4.1.bb
@@ -0,0 +1,4 @@
+require jacl_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/jacl/jacl_1.4.1.bb b/recipes/jacl/jacl_1.4.1.bb
new file mode 100644
index 0000000000..7c66c3ef7c
--- /dev/null
+++ b/recipes/jacl/jacl_1.4.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Tcl interpreter for Java"
+LICENSES = "BSD"
+
+HOMEPAGE = "http://sourceforge.net/projects/tcljava"
+
+SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/jacl${PV}"
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath src/tcljava:src/jacl -d build `find src/tcljava src/jacl -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}