summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/nano/nano.inc17
-rw-r--r--recipes/nano/nano_2.0.7.bb16
-rw-r--r--recipes/nano/nano_2.0.9.bb16
-rw-r--r--recipes/nano/nano_2.2.4.bb15
4 files changed, 26 insertions, 38 deletions
diff --git a/recipes/nano/nano.inc b/recipes/nano/nano.inc
new file mode 100644
index 0000000000..2aaaedc482
--- /dev/null
+++ b/recipes/nano/nano.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
+Not ANOther editor) is an enhanced clone of the \
+Pico text editor."
+HOMEPAGE = "http://www.nano-editor.org/"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+DEPENDS = "ncurses"
+
+INC_PR = "r0"
+
+PV_MAJOR = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+SRC_URI = "http://www.nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-all"
diff --git a/recipes/nano/nano_2.0.7.bb b/recipes/nano/nano_2.0.7.bb
index 7289d07d14..a6ff1b8c47 100644
--- a/recipes/nano/nano_2.0.7.bb
+++ b/recipes/nano/nano_2.0.7.bb
@@ -1,18 +1,8 @@
-DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
-Not ANOther editor) is an enhanced clone of the \
-Pico text editor."
-HOMEPAGE = "http://www.nano-editor.org/"
-LICENSE = "GPLv2"
-SECTION = "console/utils"
-DEPENDS = "ncurses"
+include nano.inc
-SRC_URI = "http://www.nano-editor.org/dist/v2.0/nano-${PV}.tar.gz \
- file://glib.m4"
+PR = "${INC_PR}.0"
-inherit autotools
-
-# only 16K more to get everything but the kitchen sink
-EXTRA_OECONF = "--enable-all"
+SRC_URI += "file://glib.m4"
do_configure_prepend () {
install -m 0644 ${WORKDIR}/glib.m4 m4/
diff --git a/recipes/nano/nano_2.0.9.bb b/recipes/nano/nano_2.0.9.bb
index fd9f0da9f5..479d2cc6b9 100644
--- a/recipes/nano/nano_2.0.9.bb
+++ b/recipes/nano/nano_2.0.9.bb
@@ -1,18 +1,8 @@
-DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
-Not ANOther editor) is an enhanced clone of the \
-Pico text editor."
-HOMEPAGE = "http://www.nano-editor.org/"
-LICENSE = "GPLv2"
-SECTION = "console/utils"
-DEPENDS = "ncurses"
+include nano.inc
-SRC_URI = "http://www.nano-editor.org/dist/v2.0/nano-${PV}.tar.gz \
- file://glib.m4"
+PR = "${INC_PR}.0"
-inherit autotools
-
-# only 16K more to get everything but the kitchen sink
-EXTRA_OECONF = "--enable-all"
+SRC_URI += "file://glib.m4"
do_configure_prepend () {
install -m 0644 ${WORKDIR}/glib.m4 m4/
diff --git a/recipes/nano/nano_2.2.4.bb b/recipes/nano/nano_2.2.4.bb
index b4973f8505..42fc87e415 100644
--- a/recipes/nano/nano_2.2.4.bb
+++ b/recipes/nano/nano_2.2.4.bb
@@ -1,15 +1,6 @@
-DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
-Not ANOther editor) is an enhanced clone of the \
-Pico text editor."
-HOMEPAGE = "http://www.nano-editor.org/"
-LICENSE = "GPLv2"
-SECTION = "console/utils"
-DEPENDS = "ncurses"
+include nano.inc
+
+PR = "${INC_PR}.0"
-SRC_URI = "http://www.nano-editor.org/dist/v2.2/nano-${PV}.tar.gz"
SRC_URI[md5sum] = "6304308afb1f7ef4a5e93eb99206632a"
SRC_URI[sha256sum] = "971b8547be157de5a814cb26c804dc2515b686d7188f4dc016269312965d4da5"
-
-inherit autotools
-
-EXTRA_OECONF = "--enable-all"