summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/xournal/xournal_0.4.5.bb19
2 files changed, 23 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index a2878cec22..10ce619046 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -30238,6 +30238,10 @@ sha256=bb797a384b9acb8209fea572934d1b1484c5de41f062fe152ae99962f52f98ea
md5=b3d352d08e71606383c31da5790b8d60
sha256=dff617ca33dc263caecb6afc5d42c109166ef2a1c0fe0afa070ff6691ea0e8d7
+[http://xournal.sourceforge.net/xournal-0.4.5.tar.gz]
+md5=795e4396ded2b67766eb2926be1fb4a9
+sha256=a7d7c2cb544451939779276e6e5ee5acc756bd0efb5253de15dc00bfe07755d1
+
[http://xournal.sourceforge.net/xournal-0.4.tar.gz]
md5=139ef3045c99dc5c07118b47ff9257e1
sha256=4de076c38b4b64188d23821e7d7a0f6a26b1d6707e768dadda14eb69dcc84598
diff --git a/recipes/xournal/xournal_0.4.5.bb b/recipes/xournal/xournal_0.4.5.bb
new file mode 100644
index 0000000000..747dfed826
--- /dev/null
+++ b/recipes/xournal/xournal_0.4.5.bb
@@ -0,0 +1,19 @@
+HOMEPAGE = "http://xournal.sf.net/"
+DESCRIPTION = "Xournal is an application for notetaking, sketching, keeping a journal using a stylus."
+DEPENDS = "gtk+ libgnomecanvas libgnomeprintui"
+# For pdftopnm:
+RDEPENDS = "poppler"
+SECTION = "x11"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://xournal.sourceforge.net/xournal-${PV}.tar.gz \
+ "
+
+inherit autotools pkgconfig
+
+# make desktop-install in Makefile is not useable for us, so just copy the .desktop file from source
+do_install_append () {
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${S}/xournal.desktop ${D}${datadir}/applications/
+}