summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/alsa/alsa-state.bb2
-rw-r--r--recipes/alsa/alsa-state/beagleboard/asound.state123
2 files changed, 67 insertions, 58 deletions
diff --git a/recipes/alsa/alsa-state.bb b/recipes/alsa/alsa-state.bb
index d1acf81b2c..6c8192ed86 100644
--- a/recipes/alsa/alsa-state.bb
+++ b/recipes/alsa/alsa-state.bb
@@ -7,7 +7,7 @@
DESCRIPTION = "Alsa Scenario Files"
LICENSE = "MIT"
PV = "0.2.0"
-PR = "r16"
+PR = "r17"
SRC_URI = "\
file://asound.conf \
diff --git a/recipes/alsa/alsa-state/beagleboard/asound.state b/recipes/alsa/alsa-state/beagleboard/asound.state
index f4d6f10434..f92449152c 100644
--- a/recipes/alsa/alsa-state/beagleboard/asound.state
+++ b/recipes/alsa/alsa-state/beagleboard/asound.state
@@ -216,6 +216,16 @@ state.omap3beagle {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
+ comment.item.0 'Voice high priority'
+ comment.item.1 'HiFi high priority'
+ iface MIXER
+ name 'AVADC Clock Priority'
+ value 'Voice high priority'
+ }
+ control.21 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
comment.item.0 '27/20/14 ms'
comment.item.1 '55/40/27 ms'
comment.item.2 '109/81/55 ms'
@@ -228,7 +238,7 @@ state.omap3beagle {
name 'HS ramp delay'
value '27/20/14 ms'
}
- control.21 {
+ control.22 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -238,7 +248,7 @@ state.omap3beagle {
name 'Vibra H-bridge mode'
value 'Vibra H-bridge direction'
}
- control.22 {
+ control.23 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -248,55 +258,55 @@ state.omap3beagle {
name 'Vibra H-bridge direction'
value 'Positive polarity'
}
- control.23 {
+ control.24 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Analog Right Capture Route Sub mic'
+ name 'Analog Right Sub Mic Capture Switch'
value false
}
- control.24 {
+ control.25 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Analog Right Capture Route AUXR'
+ name 'Analog Right AUXR Capture Switch'
value true
}
- control.25 {
+ control.26 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Analog Left Capture Route Main mic'
+ name 'Analog Left Main Mic Capture Switch'
value false
}
- control.26 {
+ control.27 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Analog Left Capture Route Headset mic'
+ name 'Analog Left Headset Mic Capture Switch'
value false
}
- control.27 {
+ control.28 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Analog Left Capture Route AUXL'
+ name 'Analog Left AUXL Capture Switch'
value true
}
- control.28 {
+ control.29 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Analog Left Capture Route Carkit mic'
+ name 'Analog Left Carkit Mic Capture Switch'
value false
}
- control.29 {
+ control.30 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -306,7 +316,7 @@ state.omap3beagle {
name 'TX2 Capture Route'
value Analog
}
- control.30 {
+ control.31 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -316,7 +326,7 @@ state.omap3beagle {
name 'TX1 Capture Route'
value Analog
}
- control.31 {
+ control.32 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -326,7 +336,7 @@ state.omap3beagle {
name 'Vibra Route'
value 'Local vibrator'
}
- control.32 {
+ control.33 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -338,15 +348,15 @@ state.omap3beagle {
name 'Vibra Mux'
value AudioL1
}
- control.33 {
+ control.34 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'HandsfreeR Switch Switch'
+ name 'HandsfreeR Switch'
value false
}
- control.34 {
+ control.35 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -358,15 +368,15 @@ state.omap3beagle {
name 'HandsfreeR Mux'
value Voice
}
- control.35 {
+ control.36 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'HandsfreeL Switch Switch'
+ name 'HandsfreeL Switch'
value false
}
- control.36 {
+ control.37 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -378,7 +388,7 @@ state.omap3beagle {
name 'HandsfreeL Mux'
value Voice
}
- control.37 {
+ control.38 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -386,7 +396,7 @@ state.omap3beagle {
name 'CarkitR Mixer Voice'
value false
}
- control.38 {
+ control.39 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -394,7 +404,7 @@ state.omap3beagle {
name 'CarkitR Mixer AudioR1'
value false
}
- control.39 {
+ control.40 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -402,7 +412,7 @@ state.omap3beagle {
name 'CarkitR Mixer AudioR2'
value false
}
- control.40 {
+ control.41 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -410,7 +420,7 @@ state.omap3beagle {
name 'CarkitL Mixer Voice'
value false
}
- control.41 {
+ control.42 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -418,7 +428,7 @@ state.omap3beagle {
name 'CarkitL Mixer AudioL1'
value false
}
- control.42 {
+ control.43 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -426,7 +436,7 @@ state.omap3beagle {
name 'CarkitL Mixer AudioL2'
value false
}
- control.43 {
+ control.44 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -434,7 +444,7 @@ state.omap3beagle {
name 'HeadsetR Mixer Voice'
value false
}
- control.44 {
+ control.45 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -442,7 +452,7 @@ state.omap3beagle {
name 'HeadsetR Mixer AudioR1'
value false
}
- control.45 {
+ control.46 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -450,7 +460,7 @@ state.omap3beagle {
name 'HeadsetR Mixer AudioR2'
value true
}
- control.46 {
+ control.47 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -458,7 +468,7 @@ state.omap3beagle {
name 'HeadsetL Mixer Voice'
value false
}
- control.47 {
+ control.48 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -466,7 +476,7 @@ state.omap3beagle {
name 'HeadsetL Mixer AudioL1'
value false
}
- control.48 {
+ control.49 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -474,7 +484,7 @@ state.omap3beagle {
name 'HeadsetL Mixer AudioL2'
value true
}
- control.49 {
+ control.50 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -482,7 +492,7 @@ state.omap3beagle {
name 'PredriveR Mixer Voice'
value false
}
- control.50 {
+ control.51 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -490,7 +500,7 @@ state.omap3beagle {
name 'PredriveR Mixer AudioR1'
value false
}
- control.51 {
+ control.52 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -498,7 +508,7 @@ state.omap3beagle {
name 'PredriveR Mixer AudioR2'
value false
}
- control.52 {
+ control.53 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -506,7 +516,7 @@ state.omap3beagle {
name 'PredriveR Mixer AudioL2'
value false
}
- control.53 {
+ control.54 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -514,7 +524,7 @@ state.omap3beagle {
name 'PredriveL Mixer Voice'
value false
}
- control.54 {
+ control.55 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -522,7 +532,7 @@ state.omap3beagle {
name 'PredriveL Mixer AudioL1'
value false
}
- control.55 {
+ control.56 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -530,7 +540,7 @@ state.omap3beagle {
name 'PredriveL Mixer AudioL2'
value false
}
- control.56 {
+ control.57 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -538,7 +548,7 @@ state.omap3beagle {
name 'PredriveL Mixer AudioR2'
value false
}
- control.57 {
+ control.58 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -546,7 +556,7 @@ state.omap3beagle {
name 'Earpiece Mixer Voice'
value false
}
- control.58 {
+ control.59 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -554,7 +564,7 @@ state.omap3beagle {
name 'Earpiece Mixer AudioL1'
value false
}
- control.59 {
+ control.60 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -562,7 +572,7 @@ state.omap3beagle {
name 'Earpiece Mixer AudioL2'
value false
}
- control.60 {
+ control.61 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -570,7 +580,7 @@ state.omap3beagle {
name 'Earpiece Mixer AudioR1'
value false
}
- control.61 {
+ control.62 {
comment.access 'read write'
comment.type INTEGER
comment.count 1
@@ -581,7 +591,7 @@ state.omap3beagle {
name 'Voice Digital Loopback Volume'
value 0
}
- control.62 {
+ control.63 {
comment.access 'read write'
comment.type INTEGER
comment.count 1
@@ -592,7 +602,7 @@ state.omap3beagle {
name 'Right Digital Loopback Volume'
value 0
}
- control.63 {
+ control.64 {
comment.access 'read write'
comment.type INTEGER
comment.count 1
@@ -603,7 +613,7 @@ state.omap3beagle {
name 'Left Digital Loopback Volume'
value 0
}
- control.64 {
+ control.65 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -611,7 +621,7 @@ state.omap3beagle {
name 'Voice Analog Loopback Switch'
value false
}
- control.65 {
+ control.66 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -619,7 +629,7 @@ state.omap3beagle {
name 'Left2 Analog Loopback Switch'
value false
}
- control.66 {
+ control.67 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -627,7 +637,7 @@ state.omap3beagle {
name 'Right2 Analog Loopback Switch'
value false
}
- control.67 {
+ control.68 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -635,7 +645,7 @@ state.omap3beagle {
name 'Left1 Analog Loopback Switch'
value false
}
- control.68 {
+ control.69 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -644,4 +654,3 @@ state.omap3beagle {
value false
}
}
-