aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--bitchx/bitchx_1.1.oe (renamed from pcmcia-cs/pcmcia-cs-3.2.7/busybox.patch)0
-rw-r--r--evoak/evoak_0.0.1.oe26
-rw-r--r--pcmcia-cs/pcmcia-cs-3.2.8/busybox.patch (renamed from pcmcia-cs/pcmcia-cs-3.2.7/ide.opts)0
-rw-r--r--pcmcia-cs/pcmcia-cs-3.2.8/ide.opts (renamed from pcmcia-cs/pcmcia-cs-3.2.7/network.patch)0
-rw-r--r--pcmcia-cs/pcmcia-cs-3.2.8/network.patch (renamed from pcmcia-cs/pcmcia-cs-3.2.7/wireless.opts)0
-rw-r--r--pcmcia-cs/pcmcia-cs-3.2.8/wireless.opts0
-rw-r--r--pcmcia-cs/pcmcia-cs_3.2.7.oe76
-rw-r--r--pcmcia-cs/pcmcia-cs_3.2.8.oe0
8 files changed, 26 insertions, 76 deletions
diff --git a/pcmcia-cs/pcmcia-cs-3.2.7/busybox.patch b/bitchx/bitchx_1.1.oe
index e69de29bb2..e69de29bb2 100644
--- a/pcmcia-cs/pcmcia-cs-3.2.7/busybox.patch
+++ b/bitchx/bitchx_1.1.oe
diff --git a/evoak/evoak_0.0.1.oe b/evoak/evoak_0.0.1.oe
index e69de29bb2..cf7952f67b 100644
--- a/evoak/evoak_0.0.1.oe
+++ b/evoak/evoak_0.0.1.oe
@@ -0,0 +1,26 @@
+HOMEPAGE = "http://www.enlightenment.org"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "ecore evas edje embryo eet"
+
+SRC_URI = "http://www.rasterman.com/files/evoak-${PV}.tar.gz"
+S = "${WORKDIR}/evoak-${PV}"
+
+inherit autotools binconfig
+
+export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
+export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
+export EDJE_CONFIG = "${STAGING_BINDIR}/edje-config"
+export EMBRYO_CONFIG = "${STAGING_BINDIR}/embryo-config"
+export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
+
+#FIXME: evoak fails to build, because it doesn't realize that
+#our ecore was built without X support. Ecore should really
+#be installing a copy of its config.h, and Evoak should be
+#ifdefing blocks of code based on the ecore build options.
+BROKEN = "1"
+
+do_stage () {
+ oe_libinstall -C src/lib libvoak ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/lib/Evoak.h ${STAGING_INCDIR}/
+}
diff --git a/pcmcia-cs/pcmcia-cs-3.2.7/ide.opts b/pcmcia-cs/pcmcia-cs-3.2.8/busybox.patch
index e69de29bb2..e69de29bb2 100644
--- a/pcmcia-cs/pcmcia-cs-3.2.7/ide.opts
+++ b/pcmcia-cs/pcmcia-cs-3.2.8/busybox.patch
diff --git a/pcmcia-cs/pcmcia-cs-3.2.7/network.patch b/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts
index e69de29bb2..e69de29bb2 100644
--- a/pcmcia-cs/pcmcia-cs-3.2.7/network.patch
+++ b/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts
diff --git a/pcmcia-cs/pcmcia-cs-3.2.7/wireless.opts b/pcmcia-cs/pcmcia-cs-3.2.8/network.patch
index e69de29bb2..e69de29bb2 100644
--- a/pcmcia-cs/pcmcia-cs-3.2.7/wireless.opts
+++ b/pcmcia-cs/pcmcia-cs-3.2.8/network.patch
diff --git a/pcmcia-cs/pcmcia-cs-3.2.8/wireless.opts b/pcmcia-cs/pcmcia-cs-3.2.8/wireless.opts
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/pcmcia-cs/pcmcia-cs-3.2.8/wireless.opts
diff --git a/pcmcia-cs/pcmcia-cs_3.2.7.oe b/pcmcia-cs/pcmcia-cs_3.2.7.oe
deleted file mode 100644
index a81b0f7196..0000000000
--- a/pcmcia-cs/pcmcia-cs_3.2.7.oe
+++ /dev/null
@@ -1,76 +0,0 @@
-DESCRIPTION = "Utilities and system configuration files for the Linux PCMCIA card services"
-SECTION = "base"
-PRIORITY = "required"
-LICENSE = "GPL"
-DEPENDS = "virtual/kernel"
-PR = "r3"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
- file://busybox.patch;patch=1 \
- file://network.patch;patch=1 \
- file://ide.opts \
- file://wireless.opts"
-S = "${WORKDIR}/pcmcia-cs-${PV}"
-
-INITSCRIPT_NAME = "pcmcia"
-INITSCRIPT_PARAMS = "defaults"
-
-inherit update-rc.d
-
-export KERNEL_SOURCE = ${@base_read_file('${STAGING_DIR}/${HOST_SYS}/kernel/kernel-source')}
-
-sbindir = "/sbin"
-
-do_configure() {
- touch .prereq.ok
- touch config.out
- cat >config.mk <<EOF
-UCC=${CC}
-UFLAGS=${CFLAGS} -I${S}/include
-HAS_WORDEXP=y
-SYSV_INIT=y
-RC_DIR=/etc
-CONFIG_PNP_BIOS=n
-ARCH=${ARCH}
-CONFIG_CARDBUS=n
-CONFIG_PCMCIA=y
-CONFIG_INET=y
-CONFIG_SCSI=y
-DO_IDE=y
-EOF
- cat >include/pcmcia/autoconf.h <<EOF
-#define HAS_WORDEXP 1
-EOF
-}
-
-do_compile() {
- oe_runmake all HAS_XPM= FLIBS="" XMANDIR=""
-}
-
-INSTALL_ETC = "ftl ide ieee1394 memory network parport scsi serial wireless"
-INSTALL_ETC_DATA = "config config.opts ftl.opts ieee1394.opts memory.opts network.opts parport.opts scsi.opts serial.opts shared"
-
-do_install() {
- install -d ${D}/${sbindir}
- for f in cardmgr/cardctl cardmgr/cardmgr cardmgr/ide_info cardmgr/ifport cardmgr/ifuser cardmgr/pcinitrd flash/ftl_check flash/ftl_format
- do
- install -m 0755 $f ${D}/${sbindir}/
- done
- install -d ${D}/${sysconfdir}/init.d \
- ${D}/${sysconfdir}/pcmcia \
- ${D}/${sysconfdir}/pcmcia/cis
- for i in ${INSTALL_ETC}; do
- install etc/${i} ${D}/${sysconfdir}/pcmcia/
- done
- for i in ${INSTALL_ETC_DATA}; do
- install -m 0644 etc/${i} ${D}/${sysconfdir}/pcmcia/
- done
- install -m 0644 ${WORKDIR}/ide.opts ${D}/${sysconfdir}/pcmcia/
- install -m 0644 ${WORKDIR}/wireless.opts ${D}/${sysconfdir}/pcmcia/
- for i in etc/cis/*; do
- install -m 0644 $i ${D}/${sysconfdir}/pcmcia/cis/
- done
- install -m 0755 etc/rc.pcmcia ${D}/${sysconfdir}/init.d/pcmcia
-}
-
-FILES_${PN} = "${sbindir} ${sysconfdir}"
diff --git a/pcmcia-cs/pcmcia-cs_3.2.8.oe b/pcmcia-cs/pcmcia-cs_3.2.8.oe
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/pcmcia-cs/pcmcia-cs_3.2.8.oe