aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--zip/zip_2.3.oe11
1 files changed, 9 insertions, 2 deletions
diff --git a/zip/zip_2.3.oe b/zip/zip_2.3.oe
index 529c5a8025..7ca21268d5 100644
--- a/zip/zip_2.3.oe
+++ b/zip/zip_2.3.oe
@@ -1,11 +1,18 @@
SECTION = "console/utils"
SRC_URI = "http://www.mirror.ac.uk/sites/ftp.info-zip.org/pub/infozip/src/zip23.tar.gz"
+PR = "r1"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${AS}' 'CPP=${CPP}' \
+ 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+ 'BINFLAGS=0755' 'INSTALL_D=install -d'"
do_compile() {
- make -f unix/Makefile generic
+ oe_runmake -f unix/Makefile generic
}
do_install() {
- make -f unix/Makefile install prefix=${D}${prefix}
+ oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+ BINDIR=${D}/${bindir} MANDIR=${D}/${mandir}/man1 \
+ install
}