aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/autotools.bbclass4
-rw-r--r--classes/sanity.bbclass2
-rw-r--r--conf/local.conf.sample4
-rw-r--r--recipes/help2man/help2man_1.37.1.bb22
4 files changed, 29 insertions, 3 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 2c27d0fcd1..247e21d199 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -8,9 +8,9 @@ def autotools_deps(d):
pn = bb.data.getVar('PN', d, 1)
deps = ''
- if pn in ['autoconf-native', 'automake-native']:
+ if pn in ['autoconf-native', 'automake-native', 'help2man-native']:
return deps
- deps += 'autoconf-native automake-native '
+ deps += 'autoconf-native automake-native help2man-native '
if not pn in ['libtool', 'libtool-native', 'libtool-cross']:
deps += 'libtool-native '
diff --git a/classes/sanity.bbclass b/classes/sanity.bbclass
index 575530aa84..1e6b170222 100644
--- a/classes/sanity.bbclass
+++ b/classes/sanity.bbclass
@@ -84,7 +84,7 @@ def check_sanity(e):
if not check_app_exists('${BUILD_PREFIX}g++', e.data):
missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
- required_utilities = "patch help2man diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum chrpath"
+ required_utilities = "patch diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum chrpath"
# If we'll be running qemu, perform some sanity checks
if data.getVar('ENABLE_BINARY_LOCALE_GENERATION', e.data, True):
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
index c53c03776e..1085163495 100644
--- a/conf/local.conf.sample
+++ b/conf/local.conf.sample
@@ -30,6 +30,10 @@ BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
# This is a regulary expression, so be sure to get your parenthesis balanced.
BBMASK = ""
+# Comment this if your host distribution does not provide the
+# help2man tool.
+ASSUME_PROVIDED += "help2man-native"
+
# Uncomment this if your host distribution has recent enough Linux
# Kernel header files. Utilities we use to generate certain types of
# target filesystems need somewhat recent header files.
diff --git a/recipes/help2man/help2man_1.37.1.bb b/recipes/help2man/help2man_1.37.1.bb
new file mode 100644
index 0000000000..769f86b099
--- /dev/null
+++ b/recipes/help2man/help2man_1.37.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Program to create simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+DEPENDS = "gettext-native perl-native liblocale-gettext-perl-native"
+DEPENDS_virtclass-native = "perl-native-runtime"
+RDEPENDS_pn-help2man = "gettext perl liblocale-gettext-perl"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/help4man/help2man-${PV}.tar.gz"
+SRC_URI[md5sum] = "371b5cc74fe9c2ea3ee1ca23c19b19a8"
+SRC_URI[sha256sum] = "3b44a91ef8e722c570a2a2d0e3f1cd249aac25dd2b2692c7792d87b30ed61561"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-nls"
+
+BBCLASSEXTEND = "native"
+
+# We don't want to reconfigure things as we're using host perl
+do_configure() {
+ oe_runconf
+}