aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/gnome/gnome-power_0.0.5.bb0
-rw-r--r--packages/gnome/libwnck_2.8.1.bb0
-rw-r--r--packages/hal/hal_0.5.2.bb9
3 files changed, 8 insertions, 1 deletions
diff --git a/packages/gnome/gnome-power_0.0.5.bb b/packages/gnome/gnome-power_0.0.5.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnome/gnome-power_0.0.5.bb
diff --git a/packages/gnome/libwnck_2.8.1.bb b/packages/gnome/libwnck_2.8.1.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnome/libwnck_2.8.1.bb
diff --git a/packages/hal/hal_0.5.2.bb b/packages/hal/hal_0.5.2.bb
index fc807a72bf..d02970ed1d 100644
--- a/packages/hal/hal_0.5.2.bb
+++ b/packages/hal/hal_0.5.2.bb
@@ -10,9 +10,16 @@ LICENSE = "GPL LGPL AFL"
SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
S = "${WORKDIR}/hal-${PV}"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
--with-expat=${STAGING_LIBDIR}/.. \
--with-dbus-sys=${sysconfdir}/dbus-1/system.d \
--with-hotplug=${sysconfdir}/hotplug.d"
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
+ install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
+}