aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py6
-rw-r--r--packages/python/python-2.5-manifest.inc6
-rw-r--r--packages/python/python_2.5.2.bb2
3 files changed, 7 insertions, 7 deletions
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index f33ba7e23d..3c81f33057 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -13,7 +13,7 @@ VERSION = "2.5.2"
BASEREV = 0
__author__ = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-__version__ = "20080722"
+__version__ = "20081102"
class MakefileMaker:
@@ -277,8 +277,8 @@ if __name__ == "__main__":
m.addPackage( 0, "python-pprint", "Python Pretty-Print Support", "python-core",
"pprint.*" )
- m.addPackage( 0, "python-profile", "Python Basic Profiling Support", "python-core",
- "profile.* pstats.*" )
+ m.addPackage( 0, "python-profile", "Python Basic Profiling Support", "python-core python-re",
+ "profile.* pstats.* cProfile.* lib-dynload/_lsprof.so" )
m.addPackage( 0, "python-re", "Python Regular Expression APIs", "python-core",
"re.* sre.* sre_compile.* sre_constants* sre_parse.*" ) # _sre is builtin
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index 4142a4b620..bba1b2f33d 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,5 +1,5 @@
# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
-# Generator: './generate-manifest-2.5.py' Version 20080722 (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# Generator: './generate-manifest-2.5.py' Version 20081102 (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
@@ -10,8 +10,8 @@ PACKAGES="python-profile python-threading python-distutils python-doctest python
DESCRIPTION_python-profile="Python Basic Profiling Support"
PR_python-profile="ml0"
-RDEPENDS_python-profile="python-core"
-FILES_python-profile="${libdir}/python2.5/profile.* ${libdir}/python2.5/pstats.* "
+RDEPENDS_python-profile="python-core python-re"
+FILES_python-profile="${libdir}/python2.5/profile.* ${libdir}/python2.5/pstats.* ${libdir}/python2.5/cProfile.* ${libdir}/python2.5/lib-dynload/_lsprof.so "
DESCRIPTION_python-threading="Python Threading & Synchronization Support"
PR_python-threading="ml0"
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index 19dc65b358..26a4ab828c 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml14"
+PR = "ml15"
PYTHON_MAJMIN = "2.5"