aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/rfakeap/.mtn2git_empty0
-rw-r--r--packages/rfakeap/rfakeap_0.2.bb23
2 files changed, 23 insertions, 0 deletions
diff --git a/packages/rfakeap/.mtn2git_empty b/packages/rfakeap/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rfakeap/.mtn2git_empty
diff --git a/packages/rfakeap/rfakeap_0.2.bb b/packages/rfakeap/rfakeap_0.2.bb
new file mode 100644
index 0000000000..1854e20286
--- /dev/null
+++ b/packages/rfakeap/rfakeap_0.2.bb
@@ -0,0 +1,23 @@
+SECTION = "console/network"
+DESCRIPTION = "Raw Fake AP"
+HOMEPAGE = "http://rfakeap.tuxfamily.org/"
+LICENSE = "GPLv2"
+MAINTAINER = "Zero_Chaos <sidhayn@hotmail.com>"
+DEPENDS = "libpcap"
+PV="0.2"
+PR="r1"
+
+SRC_URI = "http://rfakeap.tuxfamily.org/rfakeap-0.2.tar.gz"
+
+#EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -O3'"
+
+oe_compile() {
+ oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="-O3 ${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${sysconfdir}
+ install -m 0755 ${WORKDIR}/${PN}-${PV}/rfakeap ${D}/${sbindir}
+# install -m 0644 ap_manuf ${D}/${sysconfdir}
+}