aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/libexif/libexif_0.6.9.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/packages/libexif/libexif_0.6.9.bb b/packages/libexif/libexif_0.6.9.bb
index c40edc4c95..cd68bf1855 100644
--- a/packages/libexif/libexif_0.6.9.bb
+++ b/packages/libexif/libexif_0.6.9.bb
@@ -3,12 +3,18 @@ HOMEPAGE = "http://sourceforge.net/projects/libexif"
LICENSE = "LGPL"
SECTION = "libs"
MAINTAINER = "Eddy Pronk <epronk@muftor.com>"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.gz"
inherit autotools pkgconfig
do_stage() {
- autotools_stage_all
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-result.h exif-utils.h exif-log.h exif-mnote-data.h _stdint.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
}