aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/calamari.conf2
-rw-r--r--recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch16
-rw-r--r--recipes/u-boot/u-boot_git.bb4
3 files changed, 21 insertions, 1 deletions
diff --git a/conf/machine/calamari.conf b/conf/machine/calamari.conf
index 2f4af15d9b..dd1ad2291e 100644
--- a/conf/machine/calamari.conf
+++ b/conf/machine/calamari.conf
@@ -13,7 +13,7 @@ MACHINE_FEATURES = "kernel26 usbhost pci ext2 uboot"
KERNEL_IMAGETYPE = "uImage"
-PREFERRED_VERSION_u-boot ?= "2009.06"
+PREFERRED_VERSION_u-boot ?= "git"
UBOOT_MACHINE = "MPC8536DS_config"
UBOOT_ENTRYPOINT = "0"
UBOOT_LOADADDRESS = "0"
diff --git a/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch b/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch
new file mode 100644
index 0000000000..1ae2cb9a4b
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch
@@ -0,0 +1,16 @@
+Index: git/cpu/mpc85xx/config.mk
+===================================================================
+--- git.orig/cpu/mpc85xx/config.mk 2009-10-23 13:15:11.000000000 +0200
++++ git/cpu/mpc85xx/config.mk 2009-10-23 13:17:27.000000000 +0200
+@@ -24,6 +24,11 @@
+ PLATFORM_RELFLAGS += -fPIC -ffixed-r14 -meabi
+
+ PLATFORM_CPPFLAGS += -ffixed-r2 -Wa,-me500 -msoft-float -mno-string
++
++# -mspe=yes is needed to have -mno-spe accepted by a buggy GCC;
++# see "[PATCH,rs6000] make -mno-spe work as expected" on
++# http://gcc.gnu.org/ml/gcc-patches/2008-04/msg00311.html
++PLATFORM_CPPFLAGS +=$(call cc-option,-mspe=yes)
+ PLATFORM_CPPFLAGS +=$(call cc-option,-mno-spe)
+
+ # Use default linker script. Board port can override in board/*/config.mk
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 9958475130..730dd8dd65 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -21,6 +21,10 @@ SRC_URI_beagleboard = "git://git.denx.de/u-boot-ti.git;protocol=git \
SRCREV_beagleboard = "1590f84007e2b50ad346a482fff89195cb04ff4e"
PV_beagleboard = "2009.08+${PR}+gitr${SRCREV}"
+SRCREV_calamari = "f67066b6b0740b826ed862615c5ab022aaf4779a"
+PV_calamari = "2009.08+${PR}+gitr${SRCREV}"
+SRC_URI_append_calamari = " file://buggy-gcc-really-no-spe.patch;patch=1"
+
SRC_URI_omap3-touchbook = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
file://fw_env.config \
file://dss2.patch;patch=1 \