aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch54
-rw-r--r--recipes/opkg-utils/opkg-utils/mtime-int.patch27
-rw-r--r--recipes/opkg-utils/opkg-utils_git.bb26
-rw-r--r--recipes/opkg-utils/opkg-utils_svn.bb25
4 files changed, 26 insertions, 106 deletions
diff --git a/recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
deleted file mode 100644
index e4a548156f..0000000000
--- a/recipes/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-If we're building an image and some package rebuilds while this is happening
-some package can be removed/added to the ipk deploy directory. The image will
-not depend on this package so we can safely ignore these cases rather than
-error out.
-
-RP - 26/8/09
-
-Index: opkg-utils/opkg-make-index
-===================================================================
---- opkg-utils.orig/opkg-make-index 2009-08-26 17:21:26.000000000 +0100
-+++ opkg-utils/opkg-make-index 2009-08-27 16:11:22.000000000 +0100
-@@ -96,6 +96,7 @@
- files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
- files.sort()
- for filename in files:
-+ try:
- basename = os.path.basename(filename)
- pkg = None
- fnameStat = os.stat(filename)
-@@ -130,6 +131,12 @@
- to_morgue(basename)
- if opt_s:
- print filename
-+ except OSError:
-+ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
-+ continue
-+ except IOError:
-+ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
-+ continue
-
- pkgsStampsFile = open(stamplist_filename, "w")
- for f in pkgsStamps.keys():
-@@ -148,6 +155,7 @@
- names = packages.packages.keys()
- names.sort()
- for name in names:
-+ try:
- pkg = packages.packages[name]
- if locales_dir and pkg.depends:
- depends = string.split(pkg.depends, ',')
-@@ -165,6 +173,13 @@
- if (verbose):
- sys.stderr.write("Writing info for package %s\n" % (pkg.package,))
- print pkg
-+ except OSError:
-+ sys.stderr.write("Package %s disappeared on us!\n" % (name))
-+ continue
-+ except IOError:
-+ sys.stderr.write("Package %s disappeared on us!\n" % (name))
-+ continue
-+
- if packages_filename:
- sys.stdout.close()
- sys.stdout = old_stdout
diff --git a/recipes/opkg-utils/opkg-utils/mtime-int.patch b/recipes/opkg-utils/opkg-utils/mtime-int.patch
deleted file mode 100644
index efec3c09cc..0000000000
--- a/recipes/opkg-utils/opkg-utils/mtime-int.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Convert mtime to int before comparing it
-
-The st_mtime attribute (which is a float) is compared against a value
-from the timestamp database, which was stored as an integer there.
-
-When working on a filesystem with precise timestamps the comparision
-will fail nearly everytime hence.
-
-Although it might be possible to enhance the database to store the
-fractional part too, this will complicate things more than we would
-gain by this change.
-
-Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
-
-Index: opkg-utils/opkg-make-index
-===================================================================
---- opkg-utils.orig/opkg-make-index
-+++ opkg-utils/opkg-make-index
-@@ -100,7 +100,7 @@ for filename in files:
- pkg = None
- fnameStat = os.stat(filename)
- if old_pkg_hash.has_key(basename):
-- if pkgsStamps.has_key(basename) and fnameStat.st_mtime == pkgsStamps[basename]:
-+ if pkgsStamps.has_key(basename) and int(fnameStat.st_mtime) == pkgsStamps[basename]:
- if (verbose):
- sys.stderr.write("Found %s in Packages\n" % (filename,))
- pkg = old_pkg_hash[basename]
diff --git a/recipes/opkg-utils/opkg-utils_git.bb b/recipes/opkg-utils/opkg-utils_git.bb
new file mode 100644
index 0000000000..997b292b57
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "OPKG Package Manager Utilities"
+SECTION = "base"
+HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
+RDEPENDS_${PN} = "python"
+RDEPENDS_${PN}_virtclass-native = ""
+SRCREV = "44df9dd3dc411ca1255cb4b23bde7eb71aed4778"
+PV = "0.1.8+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=git \
+ "
+
+S = "${WORKDIR}/git"
+
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES_virtclass-native = ""
+
+do_install() {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native"
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/recipes/opkg-utils/opkg-utils_svn.bb b/recipes/opkg-utils/opkg-utils_svn.bb
deleted file mode 100644
index 6b8d3ea682..0000000000
--- a/recipes/opkg-utils/opkg-utils_svn.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "OPKG Package Manager Utilities"
-SECTION = "base"
-HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
-PRIORITY = "optional"
-RDEPENDS_${PN} = "python"
-RDEPENDS_${PN}_virtclass-native = ""
-SRCREV = "4747"
-PV = "0.1.8+svnr${SRCPV}"
-PR = "r6"
-
-SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
- file://index-ignore-filenotfound.patch \
- file://mtime-int.patch"
-
-S = "${WORKDIR}/opkg-utils"
-
-# Avoid circular dependencies from package_ipk.bbclass
-PACKAGES_virtclass-native = ""
-
-do_install() {
- oe_runmake PREFIX=${prefix} DESTDIR=${D} install
-}
-
-BBCLASSEXTEND = "native"
-TARGET_CC_ARCH += "${LDFLAGS}"