aboutsummaryrefslogtreecommitdiffstats
path: root/bash/bash-2.05b/rl-examples.patch
diff options
context:
space:
mode:
Diffstat (limited to 'bash/bash-2.05b/rl-examples.patch')
-rw-r--r--bash/bash-2.05b/rl-examples.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/bash/bash-2.05b/rl-examples.patch b/bash/bash-2.05b/rl-examples.patch
index e69de29bb2..a6ea709a9e 100644
--- a/bash/bash-2.05b/rl-examples.patch
+++ b/bash/bash-2.05b/rl-examples.patch
@@ -0,0 +1,24 @@
+--- ./lib/readline/examples/Makefile.orig Fri Nov 26 23:13:35 1999
++++ ./lib/readline/examples/Makefile Fri Nov 26 23:15:19 1999
+@@ -1,8 +1,8 @@
+ # This is the Makefile for the examples subdirectory of readline. -*- text -*-
+ #
+ EXECUTABLES = fileman rltest rl
+-CFLAGS = -g -I../.. -I.. -DREADLINE_LIBRARY
+-LDFLAGS = -g -L..
++CFLAGS = -g
++LDFLAGS = -g
+
+ .c.o:
+ $(CC) $(CFLAGS) -c $<
+--- ./lib/readline/examples/rl.c~ Mon Nov 8 22:22:03 1999
++++ ./lib/readline/examples/rl.c Fri Dec 31 17:34:30 1999
+@@ -11,7 +11,7 @@
+
+ #include <stdio.h>
+ #include <sys/types.h>
+-#include "posixstat.h"
++#include <sys/stat.h>
+
+ #if defined (READLINE_LIBRARY)
+ # include "readline.h"