aboutsummaryrefslogtreecommitdiffstats
path: root/dropbear
diff options
context:
space:
mode:
Diffstat (limited to 'dropbear')
-rw-r--r--dropbear/dropbear-0.41/allow-nopw.patch39
-rw-r--r--dropbear/dropbear-0.41/configure.patch31
-rw-r--r--dropbear/dropbear-0.41/initd.patch21
-rw-r--r--dropbear/dropbear-0.42/allow-nopw.patch39
-rw-r--r--dropbear/dropbear-0.42/configure.patch31
-rw-r--r--dropbear/dropbear-0.42/multi-binary.patch11
-rw-r--r--dropbear/dropbear-0.43+0.44test4/allow-nopw.patch40
-rw-r--r--dropbear/dropbear-0.43+0.44test4/configure.patch31
-rw-r--r--dropbear/dropbear-0.43+0.44test4/multi-binary.patch11
-rw-r--r--dropbear/dropbear-0.43+0.44test4/xauth-path.patch11
-rw-r--r--dropbear/dropbear-0.43/allow-nopw.patch39
-rw-r--r--dropbear/dropbear-0.43/configure.patch31
-rw-r--r--dropbear/dropbear-0.43/multi-binary.patch11
13 files changed, 346 insertions, 0 deletions
diff --git a/dropbear/dropbear-0.41/allow-nopw.patch b/dropbear/dropbear-0.41/allow-nopw.patch
index e69de29bb2..cc916a8242 100644
--- a/dropbear/dropbear-0.41/allow-nopw.patch
+++ b/dropbear/dropbear-0.41/allow-nopw.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.41/auth.c~allow-nopw
++++ dropbear-0.41/auth.c
+@@ -225,6 +225,7 @@
+ }
+
+ /* check for an empty password */
++#ifdef DISALLOW_EMPTY_PW
+ if (ses.authstate.pw->pw_passwd[0] == '\0') {
+ TRACE(("leave checkusername: empty pword"));
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+@@ -232,6 +233,7 @@
+ send_msg_userauth_failure(0, 1);
+ return DROPBEAR_FAILURE;
+ }
++#endif
+
+ TRACE(("shell is %s", ses.authstate.pw->pw_shell));
+
+--- dropbear-0.41/authpasswd.c~allow-nopw
++++ dropbear-0.41/authpasswd.c
+@@ -65,9 +65,13 @@
+ * since the shadow password may differ to that tested
+ * in auth.c */
+ if (passwdcrypt[0] == '\0') {
++#ifdef DISALLOW_EMPTY_PASSWD
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+ ses.authstate.printableuser);
+ send_msg_userauth_failure(0, 1);
++#else
++ send_msg_userauth_success();
++#endif
+ return;
+ }
+
diff --git a/dropbear/dropbear-0.41/configure.patch b/dropbear/dropbear-0.41/configure.patch
index e69de29bb2..cfc15f826b 100644
--- a/dropbear/dropbear-0.41/configure.patch
+++ b/dropbear/dropbear-0.41/configure.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.40/configure.in~configure
++++ dropbear-0.40/configure.in
+@@ -125,15 +125,20 @@
+ AC_MSG_RESULT(Not using openpty)
+ else
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ fi
+ ],
+ [
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ ]
+ )
+-
++
++if test "x$dropbear_cv_func_have_openpty" = "xyes"; then
++ AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)
++ no_ptc_check=yes
++ no_ptmx_check=yes
++fi
+
+ AC_ARG_ENABLE(syslog,
+ [ --disable-syslog Don't include syslog support],
diff --git a/dropbear/dropbear-0.41/initd.patch b/dropbear/dropbear-0.41/initd.patch
index e69de29bb2..b324241b6e 100644
--- a/dropbear/dropbear-0.41/initd.patch
+++ b/dropbear/dropbear-0.41/initd.patch
@@ -0,0 +1,21 @@
+diff -Naur dropbear-0.41-oe/debian/dropbear.init dropbear-0.41/debian/dropbear.init
+--- dropbear-0.41-oe/debian/dropbear.init 2003-06-22 16:04:18.000000000 +0200
++++ dropbear-0.41/debian/dropbear.init 2004-05-10 18:08:32.000000000 +0200
+@@ -50,7 +50,7 @@
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+- start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/$NAME.pid
++ start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid
+ echo "$NAME."
+ ;;
+ restart|force-reload)
+@@ -60,7 +60,7 @@
+ # just the same as "restart".
+ #
+ echo -n "Restarting $DESC: "
+- start-stop-daemon --stop --quiet --oknodo --pidfile \
++ start-stop-daemon --stop --quiet --pidfile \
+ /var/run/$NAME.pid
+ sleep 1
+ start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
diff --git a/dropbear/dropbear-0.42/allow-nopw.patch b/dropbear/dropbear-0.42/allow-nopw.patch
index e69de29bb2..cc916a8242 100644
--- a/dropbear/dropbear-0.42/allow-nopw.patch
+++ b/dropbear/dropbear-0.42/allow-nopw.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.41/auth.c~allow-nopw
++++ dropbear-0.41/auth.c
+@@ -225,6 +225,7 @@
+ }
+
+ /* check for an empty password */
++#ifdef DISALLOW_EMPTY_PW
+ if (ses.authstate.pw->pw_passwd[0] == '\0') {
+ TRACE(("leave checkusername: empty pword"));
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+@@ -232,6 +233,7 @@
+ send_msg_userauth_failure(0, 1);
+ return DROPBEAR_FAILURE;
+ }
++#endif
+
+ TRACE(("shell is %s", ses.authstate.pw->pw_shell));
+
+--- dropbear-0.41/authpasswd.c~allow-nopw
++++ dropbear-0.41/authpasswd.c
+@@ -65,9 +65,13 @@
+ * since the shadow password may differ to that tested
+ * in auth.c */
+ if (passwdcrypt[0] == '\0') {
++#ifdef DISALLOW_EMPTY_PASSWD
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+ ses.authstate.printableuser);
+ send_msg_userauth_failure(0, 1);
++#else
++ send_msg_userauth_success();
++#endif
+ return;
+ }
+
diff --git a/dropbear/dropbear-0.42/configure.patch b/dropbear/dropbear-0.42/configure.patch
index e69de29bb2..cfc15f826b 100644
--- a/dropbear/dropbear-0.42/configure.patch
+++ b/dropbear/dropbear-0.42/configure.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.40/configure.in~configure
++++ dropbear-0.40/configure.in
+@@ -125,15 +125,20 @@
+ AC_MSG_RESULT(Not using openpty)
+ else
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ fi
+ ],
+ [
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ ]
+ )
+-
++
++if test "x$dropbear_cv_func_have_openpty" = "xyes"; then
++ AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)
++ no_ptc_check=yes
++ no_ptmx_check=yes
++fi
+
+ AC_ARG_ENABLE(syslog,
+ [ --disable-syslog Don't include syslog support],
diff --git a/dropbear/dropbear-0.42/multi-binary.patch b/dropbear/dropbear-0.42/multi-binary.patch
index e69de29bb2..280ebf0128 100644
--- a/dropbear/dropbear-0.42/multi-binary.patch
+++ b/dropbear/dropbear-0.42/multi-binary.patch
@@ -0,0 +1,11 @@
+--- dropbear-0.42/options.h.orig 2004-06-16 07:08:27.000000000 +0200
++++ dropbear-0.42/options.h 2004-07-04 22:41:25.000000000 +0200
+@@ -184,7 +184,7 @@
+ * "make clean; make dropbearmulti". You'll need to install the binary
+ * manually, see MULTI for details */
+
+-/* #define DROPBEAR_MULTI */
++#define DROPBEAR_MULTI
+
+ /* The three multi binaries: dropbear, dropbearkey, dropbearconvert
+ * Comment out these if you don't want some of them */
diff --git a/dropbear/dropbear-0.43+0.44test4/allow-nopw.patch b/dropbear/dropbear-0.43+0.44test4/allow-nopw.patch
index e69de29bb2..a3f205b97d 100644
--- a/dropbear/dropbear-0.43+0.44test4/allow-nopw.patch
+++ b/dropbear/dropbear-0.43+0.44test4/allow-nopw.patch
@@ -0,0 +1,40 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- dropbear-0.44test3/svr-auth.c~allow-nopw
++++ dropbear-0.44test3/svr-auth.c
+@@ -222,6 +222,7 @@
+ }
+
+ /* check for an empty password */
++#ifdef DISALLOW_EMPTY_PW
+ if (ses.authstate.pw->pw_passwd[0] == '\0') {
+ TRACE(("leave checkusername: empty pword"));
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+@@ -229,7 +230,7 @@
+ send_msg_userauth_failure(0, 1);
+ return DROPBEAR_FAILURE;
+ }
+-
++#endif
+ TRACE(("shell is %s", ses.authstate.pw->pw_shell));
+
+ /* check that the shell is set */
+--- dropbear-0.44test3/svr-authpasswd.c~allow-nopw
++++ dropbear-0.44test3/svr-authpasswd.c
+@@ -64,9 +64,13 @@
+ * since the shadow password may differ to that tested
+ * in auth.c */
+ if (passwdcrypt[0] == '\0') {
++#ifdef DISALLOW_EMPTY_PASSWD
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+ ses.authstate.printableuser);
+ send_msg_userauth_failure(0, 1);
++#else
++ send_msg_userauth_success();
++#endif
+ return;
+ }
+
diff --git a/dropbear/dropbear-0.43+0.44test4/configure.patch b/dropbear/dropbear-0.43+0.44test4/configure.patch
index e69de29bb2..cfc15f826b 100644
--- a/dropbear/dropbear-0.43+0.44test4/configure.patch
+++ b/dropbear/dropbear-0.43+0.44test4/configure.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.40/configure.in~configure
++++ dropbear-0.40/configure.in
+@@ -125,15 +125,20 @@
+ AC_MSG_RESULT(Not using openpty)
+ else
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ fi
+ ],
+ [
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ ]
+ )
+-
++
++if test "x$dropbear_cv_func_have_openpty" = "xyes"; then
++ AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)
++ no_ptc_check=yes
++ no_ptmx_check=yes
++fi
+
+ AC_ARG_ENABLE(syslog,
+ [ --disable-syslog Don't include syslog support],
diff --git a/dropbear/dropbear-0.43+0.44test4/multi-binary.patch b/dropbear/dropbear-0.43+0.44test4/multi-binary.patch
index e69de29bb2..280ebf0128 100644
--- a/dropbear/dropbear-0.43+0.44test4/multi-binary.patch
+++ b/dropbear/dropbear-0.43+0.44test4/multi-binary.patch
@@ -0,0 +1,11 @@
+--- dropbear-0.42/options.h.orig 2004-06-16 07:08:27.000000000 +0200
++++ dropbear-0.42/options.h 2004-07-04 22:41:25.000000000 +0200
+@@ -184,7 +184,7 @@
+ * "make clean; make dropbearmulti". You'll need to install the binary
+ * manually, see MULTI for details */
+
+-/* #define DROPBEAR_MULTI */
++#define DROPBEAR_MULTI
+
+ /* The three multi binaries: dropbear, dropbearkey, dropbearconvert
+ * Comment out these if you don't want some of them */
diff --git a/dropbear/dropbear-0.43+0.44test4/xauth-path.patch b/dropbear/dropbear-0.43+0.44test4/xauth-path.patch
index e69de29bb2..4a820f5654 100644
--- a/dropbear/dropbear-0.43+0.44test4/xauth-path.patch
+++ b/dropbear/dropbear-0.43+0.44test4/xauth-path.patch
@@ -0,0 +1,11 @@
+--- dropbear-0.44test4/options.h.orig 2004-10-01 23:53:33.000000000 +0200
++++ dropbear-0.44test4/options.h 2004-10-01 23:53:59.000000000 +0200
+@@ -161,7 +161,7 @@
+ /* The command to invoke for xauth when using X11 forwarding.
+ * "-q" for quiet */
+ #ifndef XAUTH_COMMAND
+-#define XAUTH_COMMAND "/usr/X11R6/bin/xauth -q"
++#define XAUTH_COMMAND "xauth -q"
+ #endif
+
+ /* if you want to enable running an sftp server (such as the one included with
diff --git a/dropbear/dropbear-0.43/allow-nopw.patch b/dropbear/dropbear-0.43/allow-nopw.patch
index e69de29bb2..cc916a8242 100644
--- a/dropbear/dropbear-0.43/allow-nopw.patch
+++ b/dropbear/dropbear-0.43/allow-nopw.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.41/auth.c~allow-nopw
++++ dropbear-0.41/auth.c
+@@ -225,6 +225,7 @@
+ }
+
+ /* check for an empty password */
++#ifdef DISALLOW_EMPTY_PW
+ if (ses.authstate.pw->pw_passwd[0] == '\0') {
+ TRACE(("leave checkusername: empty pword"));
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+@@ -232,6 +233,7 @@
+ send_msg_userauth_failure(0, 1);
+ return DROPBEAR_FAILURE;
+ }
++#endif
+
+ TRACE(("shell is %s", ses.authstate.pw->pw_shell));
+
+--- dropbear-0.41/authpasswd.c~allow-nopw
++++ dropbear-0.41/authpasswd.c
+@@ -65,9 +65,13 @@
+ * since the shadow password may differ to that tested
+ * in auth.c */
+ if (passwdcrypt[0] == '\0') {
++#ifdef DISALLOW_EMPTY_PASSWD
+ dropbear_log(LOG_WARNING, "user '%s' has blank password, rejected",
+ ses.authstate.printableuser);
+ send_msg_userauth_failure(0, 1);
++#else
++ send_msg_userauth_success();
++#endif
+ return;
+ }
+
diff --git a/dropbear/dropbear-0.43/configure.patch b/dropbear/dropbear-0.43/configure.patch
index e69de29bb2..cfc15f826b 100644
--- a/dropbear/dropbear-0.43/configure.patch
+++ b/dropbear/dropbear-0.43/configure.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dropbear-0.40/configure.in~configure
++++ dropbear-0.40/configure.in
+@@ -125,15 +125,20 @@
+ AC_MSG_RESULT(Not using openpty)
+ else
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ fi
+ ],
+ [
+ AC_MSG_RESULT(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ ]
+ )
+-
++
++if test "x$dropbear_cv_func_have_openpty" = "xyes"; then
++ AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)
++ no_ptc_check=yes
++ no_ptmx_check=yes
++fi
+
+ AC_ARG_ENABLE(syslog,
+ [ --disable-syslog Don't include syslog support],
diff --git a/dropbear/dropbear-0.43/multi-binary.patch b/dropbear/dropbear-0.43/multi-binary.patch
index e69de29bb2..280ebf0128 100644
--- a/dropbear/dropbear-0.43/multi-binary.patch
+++ b/dropbear/dropbear-0.43/multi-binary.patch
@@ -0,0 +1,11 @@
+--- dropbear-0.42/options.h.orig 2004-06-16 07:08:27.000000000 +0200
++++ dropbear-0.42/options.h 2004-07-04 22:41:25.000000000 +0200
+@@ -184,7 +184,7 @@
+ * "make clean; make dropbearmulti". You'll need to install the binary
+ * manually, see MULTI for details */
+
+-/* #define DROPBEAR_MULTI */
++#define DROPBEAR_MULTI
+
+ /* The three multi binaries: dropbear, dropbearkey, dropbearconvert
+ * Comment out these if you don't want some of them */