aboutsummaryrefslogtreecommitdiffstats
path: root/gawk/gawk-3.0.4/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gawk/gawk-3.0.4/configure.patch')
-rw-r--r--gawk/gawk-3.0.4/configure.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/gawk/gawk-3.0.4/configure.patch b/gawk/gawk-3.0.4/configure.patch
index e69de29bb2..8a3e7a12ea 100644
--- a/gawk/gawk-3.0.4/configure.patch
+++ b/gawk/gawk-3.0.4/configure.patch
@@ -0,0 +1,53 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- gawk-3.0.4/./configure.in~configure
++++ gawk-3.0.4/./configure.in
+@@ -27,8 +27,9 @@
+ dnl define(AC_CONFIG_AUX_DIR,)
+
+ dnl This is the configure.in script proper
+-AC_INIT(awk.h)
+-AC_PREREQ(2.12)
++AC_INIT
++AC_CONFIG_SRCDIR([awk.h])
++AC_PREREQ(2.57)
+ AC_CONFIG_HEADER(config.h:configh.in)
+ AC_CANONICAL_HOST
+
+@@ -91,7 +92,7 @@
+ dnl checks for typedefs
+ AC_TYPE_PID_T
+ AC_TYPE_SIGNAL
+-AC_SIZE_T
++AC_TYPE_SIZE_T([])
+ AC_TYPE_GETGROUPS
+ AC_EGREP_HEADER([int.*sprintf], stdio.h,
+ AC_DEFINE(SPRINTF_RET, int),
+@@ -145,7 +146,15 @@
+ fi
+
+ dnl checks for structure members
+-AC_STRUCT_ST_BLKSIZE
++AC_DIAGNOSE([obsolete],[AC_STRUCT_ST_BLKSIZE:
++ your code should no longer depend upon `HAVE_ST_BLKSIZE', but
++ `HAVE_STRUCT_STAT_ST_BLKSIZE'. Remove this warning and
++ the `AC_DEFINE' when you adjust the code.])
++AC_CHECK_MEMBERS([struct stat.st_blksize],[AC_DEFINE(HAVE_ST_BLKSIZE, 1,
++ [Define to 1 if your `struct stat' has
++ `st_blksize'. Deprecated, use
++ `HAVE_STRUCT_STAT_ST_BLKSIZE' instead.])])
++
+ AC_HEADER_TIME
+ AC_STRUCT_TM
+ AC_STRUCT_TIMEZONE
+@@ -155,4 +164,6 @@
+ AC_C_CONST
+ GAWK_AC_C_STRINGIZE
+
+-AC_OUTPUT(Makefile doc/Makefile test/Makefile awklib/Makefile, [date > stamp-h])
++AC_CONFIG_FILES([Makefile doc/Makefile test/Makefile awklib/Makefile])
++AC_CONFIG_COMMANDS([default],[[date > stamp-h]],[[]])
++AC_OUTPUT