aboutsummaryrefslogtreecommitdiffstats
path: root/gpsd
diff options
context:
space:
mode:
Diffstat (limited to 'gpsd')
-rw-r--r--gpsd/gpsd-1.10-r0/gcc3.patch11
-rw-r--r--gpsd/gpsd-1.10-r0/gcc34.patch16
-rw-r--r--gpsd/gpsd-1.10-r0/gpsdc.patch29
-rw-r--r--gpsd/gpsd-1.10-r0/nmea-fix.patch24
-rw-r--r--gpsd/gpsd-qpegps-0.9.2/gcc3.patch11
-rw-r--r--gpsd/gpsd-qpegps-0.9.2/nmea-fix.patch24
6 files changed, 115 insertions, 0 deletions
diff --git a/gpsd/gpsd-1.10-r0/gcc3.patch b/gpsd/gpsd-1.10-r0/gcc3.patch
index e69de29bb2..191405e909 100644
--- a/gpsd/gpsd-1.10-r0/gcc3.patch
+++ b/gpsd/gpsd-1.10-r0/gcc3.patch
@@ -0,0 +1,11 @@
+--- gpsd-1.07/netlib.c~gcc3 2002-04-02 04:48:10.000000000 +0200
++++ gpsd-1.07/netlib.c 2003-08-07 20:52:38.000000000 +0200
+@@ -9,7 +9,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include <netdb.h>
+ #include <stdio.h>
+ #include <arpa/inet.h>
diff --git a/gpsd/gpsd-1.10-r0/gcc34.patch b/gpsd/gpsd-1.10-r0/gcc34.patch
index e69de29bb2..00132cc7d4 100644
--- a/gpsd/gpsd-1.10-r0/gcc34.patch
+++ b/gpsd/gpsd-1.10-r0/gcc34.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- gpsd-1.10/Makefile.in~gcc34.patch 2003-08-27 05:43:51.000000000 +0200
++++ gpsd-1.10/Makefile.in 2004-06-13 23:40:12.000000000 +0200
+@@ -126,7 +126,7 @@
+ all: $(PROGRAMS) $(MOTIF_PROGRAMS)
+
+ gpsd: gpsd.o libgpsd.a
+- $(LINK.c) -o $@ gpsd.o -L. -lgpsd $(NETLIBS) $(LIBS)
++ $(LINK.c) -o $@ gpsd.o -L. -lgpsd $(NETLIBS) -lm
+
+ gpsplay: gpsplay.o libgpsd.a
+ $(LINK.c) -o $@ gpsplay.o -L. -lgpsd $(NETLIBS) $(LIBS)
diff --git a/gpsd/gpsd-1.10-r0/gpsdc.patch b/gpsd/gpsd-1.10-r0/gpsdc.patch
index e69de29bb2..61886e54fc 100644
--- a/gpsd/gpsd-1.10-r0/gpsdc.patch
+++ b/gpsd/gpsd-1.10-r0/gpsdc.patch
@@ -0,0 +1,29 @@
+--- gpsd-1.10/gpsd.c.orig 2004-03-12 20:25:22.281457600 +0000
++++ gpsd-1.10/gpsd.c 2004-03-12 20:27:55.263200840 +0000
+@@ -529,6 +529,26 @@
+ ",G=%6.6s",
+ gNMEAdata.grid);
+ break;
++ case 'H':
++ case 'h':
++ sprintf(reply + strlen(reply),
++ ",H=%f",
++ gNMEAdata.track);
++ break;
++ case 'X':
++ case 'x':
++ if (!FD_ISSET(fd, fds))
++ FD_SET(fd, fds);
++ sprintf(reply + strlen(reply),
++ " ,R=1");
++ break;
++ case 'C':
++ case 'c':
++ if (FD_ISSET(fd, fds))
++ FD_CLR(fd, fds);
++ sprintf(reply + strlen(reply),
++ " ,R=0");
++ break;
+ case 'R':
+ case 'r':
+ if (FD_ISSET(fd, fds)) {
diff --git a/gpsd/gpsd-1.10-r0/nmea-fix.patch b/gpsd/gpsd-1.10-r0/nmea-fix.patch
index e69de29bb2..8d6ec0b3ea 100644
--- a/gpsd/gpsd-1.10-r0/nmea-fix.patch
+++ b/gpsd/gpsd-1.10-r0/nmea-fix.patch
@@ -0,0 +1,24 @@
+--- gpsd-1.10/nmea_parse.c.orig 2004-03-01 23:32:52.147650832 +0000
++++ gpsd-1.10/nmea_parse.c 2004-03-01 23:32:43.544958640 +0000
+@@ -261,7 +261,7 @@
+ unsigned char sum = '\0';
+ char c, *p = sentence;
+
+- while ((c = *p++) != '*')
++ while ((c = *p++) != '*' && c != '\0')
+ sum ^= c;
+
+ sprintf(p, "%02X\r\n", sum);
+@@ -276,10 +276,10 @@
+ static char *field(char *sentence, short n)
+ {
+ static char result[100];
+- char *p = sentence;
++ char c, *p = sentence;
+
+ while (n-- > 0)
+- while (*p++ != ',');
++ while ((c = *p++) != ',' && c != '\0');
+ strcpy(result, p);
+ p = result;
+ while (*p && *p != ',' && *p != '*' && *p != '\r')
diff --git a/gpsd/gpsd-qpegps-0.9.2/gcc3.patch b/gpsd/gpsd-qpegps-0.9.2/gcc3.patch
index e69de29bb2..191405e909 100644
--- a/gpsd/gpsd-qpegps-0.9.2/gcc3.patch
+++ b/gpsd/gpsd-qpegps-0.9.2/gcc3.patch
@@ -0,0 +1,11 @@
+--- gpsd-1.07/netlib.c~gcc3 2002-04-02 04:48:10.000000000 +0200
++++ gpsd-1.07/netlib.c 2003-08-07 20:52:38.000000000 +0200
+@@ -9,7 +9,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include <netdb.h>
+ #include <stdio.h>
+ #include <arpa/inet.h>
diff --git a/gpsd/gpsd-qpegps-0.9.2/nmea-fix.patch b/gpsd/gpsd-qpegps-0.9.2/nmea-fix.patch
index e69de29bb2..8d6ec0b3ea 100644
--- a/gpsd/gpsd-qpegps-0.9.2/nmea-fix.patch
+++ b/gpsd/gpsd-qpegps-0.9.2/nmea-fix.patch
@@ -0,0 +1,24 @@
+--- gpsd-1.10/nmea_parse.c.orig 2004-03-01 23:32:52.147650832 +0000
++++ gpsd-1.10/nmea_parse.c 2004-03-01 23:32:43.544958640 +0000
+@@ -261,7 +261,7 @@
+ unsigned char sum = '\0';
+ char c, *p = sentence;
+
+- while ((c = *p++) != '*')
++ while ((c = *p++) != '*' && c != '\0')
+ sum ^= c;
+
+ sprintf(p, "%02X\r\n", sum);
+@@ -276,10 +276,10 @@
+ static char *field(char *sentence, short n)
+ {
+ static char result[100];
+- char *p = sentence;
++ char c, *p = sentence;
+
+ while (n-- > 0)
+- while (*p++ != ',');
++ while ((c = *p++) != ',' && c != '\0');
+ strcpy(result, p);
+ p = result;
+ while (*p && *p != ',' && *p != '*' && *p != '\r')