aboutsummaryrefslogtreecommitdiffstats
path: root/gstreamer
diff options
context:
space:
mode:
Diffstat (limited to 'gstreamer')
-rw-r--r--gstreamer/files/ivorbis.patch12
-rw-r--r--gstreamer/files/lame-autoconf.patch18
-rw-r--r--gstreamer/files/try-esdsink.patch22
-rw-r--r--gstreamer/gstreamer/configure-largefile.patch13
-rw-r--r--gstreamer/gstreamer/gstreamer.xsession4
5 files changed, 69 insertions, 0 deletions
diff --git a/gstreamer/files/ivorbis.patch b/gstreamer/files/ivorbis.patch
index e69de29bb2..22949f5e20 100644
--- a/gstreamer/files/ivorbis.patch
+++ b/gstreamer/files/ivorbis.patch
@@ -0,0 +1,12 @@
+--- gst-plugins-0.8.1/ext/ivorbis/vorbis.c.old 2004-06-02 09:12:54.000000000 +0100
++++ gst-plugins-0.8.1/ext/ivorbis/vorbis.c 2004-06-02 09:12:32.000000000 +0100
+@@ -21,7 +21,8 @@
+ #include <config.h>
+ #endif
+
+-#include <vorbisenc.h>
++#include <gst/gst.h>
++#include <tremor/ivorbiscodec.h>
+
+ extern GType ivorbisfile_get_type (void);
+
diff --git a/gstreamer/files/lame-autoconf.patch b/gstreamer/files/lame-autoconf.patch
index e69de29bb2..db62dbd71d 100644
--- a/gstreamer/files/lame-autoconf.patch
+++ b/gstreamer/files/lame-autoconf.patch
@@ -0,0 +1,18 @@
+--- gst-plugins-0.8.4/configure.ac.old 2004-09-11 00:35:27.000000000 +0100
++++ gst-plugins-0.8.4/configure.ac 2004-09-11 00:35:27.000000000 +0100
+@@ -1196,6 +1196,7 @@
+ GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame -lm")
+ ])
+ dnl is lame presets available
++if test "x$HAVE_LAME" = "xyes"; then
+ LAME_CFLAGS=""
+ AC_TRY_RUN([
+ #include <lame/lame.h>
+@@ -1205,6 +1206,7 @@
+ return 0;
+ }
+ ],[LAME_CFLAGS="-DGSTLAME_PRESET"],[LAME_CFLAGS=""])
++fi
+ AC_SUBST(LAME_CFLAGS)
+ AC_SUBST(LAME_LIBS)
+
diff --git a/gstreamer/files/try-esdsink.patch b/gstreamer/files/try-esdsink.patch
index e69de29bb2..9c6242663c 100644
--- a/gstreamer/files/try-esdsink.patch
+++ b/gstreamer/files/try-esdsink.patch
@@ -0,0 +1,22 @@
+--- gst-plugins-0.8.1/gst-libs/gst/gconf/gconf.c~ 2004-08-17 17:55:46.000000000 +0100
++++ gst-plugins-0.8.1/gst-libs/gst/gconf/gconf.c 2004-08-17 18:04:00.000000000 +0100
+@@ -204,10 +204,16 @@
+ if (!ret) {
+ ret = gst_element_factory_make ("osssink", NULL);
+
+- if (!ret)
+- g_warning ("No GConf default audio sink key and osssink doesn't work");
+- else
++ if (!ret) {
++ ret = gst_element_factory_make ("esdsink", NULL);
++
++ if (!ret)
++ g_warning ("No GConf default audio sink key and osssink & esdsink don't work");
++ else
++ g_print ("GConf audio sink and osssink not found, using esdsink\n");
++ } else {
+ g_print ("GConf audio sink not found, using osssink\n");
++ }
+ }
+
+ return ret;
diff --git a/gstreamer/gstreamer/configure-largefile.patch b/gstreamer/gstreamer/configure-largefile.patch
index e69de29bb2..6ea1ef3dba 100644
--- a/gstreamer/gstreamer/configure-largefile.patch
+++ b/gstreamer/gstreamer/configure-largefile.patch
@@ -0,0 +1,13 @@
+--- configure.ac~ 2004-06-03 12:37:47.000000000 +0100
++++ configure.ac 2004-06-04 13:31:02.000000000 +0100
+@@ -172,6 +172,10 @@
+ ],
+ [
+ AC_MSG_RESULT(no)
++],
++[
++ AC_MSG_RESULT(cross-compiling, assumed yes)
++ GST_PKG_CFLAGS="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ ])
+
+ dnl check for mmap
diff --git a/gstreamer/gstreamer/gstreamer.xsession b/gstreamer/gstreamer/gstreamer.xsession
index e69de29bb2..a260a8d142 100644
--- a/gstreamer/gstreamer/gstreamer.xsession
+++ b/gstreamer/gstreamer/gstreamer.xsession
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gst-register
+