aboutsummaryrefslogtreecommitdiffstats
path: root/hostap/hostap-modules-0.2.4/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'hostap/hostap-modules-0.2.4/Makefile.patch')
-rw-r--r--hostap/hostap-modules-0.2.4/Makefile.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/hostap/hostap-modules-0.2.4/Makefile.patch b/hostap/hostap-modules-0.2.4/Makefile.patch
index e69de29bb2..2fc5e9ed4b 100644
--- a/hostap/hostap-modules-0.2.4/Makefile.patch
+++ b/hostap/hostap-modules-0.2.4/Makefile.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
++++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ VERFILE := $(KERNEL_PATH)/include/linux/version.h
+ KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
+- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
++ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
+ else uname -r; fi)
+ KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
+ sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")