aboutsummaryrefslogtreecommitdiffstats
path: root/libusb/libusb-0.1.7/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libusb/libusb-0.1.7/configure.patch')
-rw-r--r--libusb/libusb-0.1.7/configure.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/libusb/libusb-0.1.7/configure.patch b/libusb/libusb-0.1.7/configure.patch
index e69de29bb2..5f78908da2 100644
--- a/libusb/libusb-0.1.7/configure.patch
+++ b/libusb/libusb-0.1.7/configure.patch
@@ -0,0 +1,99 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libusb-0.1.7/configure.in~configure
++++ libusb-0.1.7/configure.in
+@@ -1,17 +1,18 @@
+ # This configure.in is based off of the one that glib uses
+
+ # require atleast autoconf 2.13
+-AC_PREREQ(2.13)
++AC_PREREQ(2.57)
+
+ # init autoconf (and check for presence of usb.c)
+-AC_INIT(usb.c)
++AC_INIT
++AC_CONFIG_SRCDIR([usb.c])
+
+ # Save this value here, since automake will set cflags later
+ cflags_set=${CFLAGS+set}
+
+ dnl we need to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
+ dnl are available for $ac_help expansion (don't we all *love* autoconf?)
+-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
++dnl AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+
+ #
+ # The following version number definitions apply to libusb
+@@ -33,7 +34,7 @@
+ LIBUSB_BINARY_AGE=3
+ LIBUSB_VERSION=$LIBUSB_MAJOR_VERSION.$LIBUSB_MINOR_VERSION.$LIBUSB_MICRO_VERSION
+ dnl
+-AC_DIVERT_POP()dnl
++dnl AC_DIVERT_POP()dnl
+
+ AC_SUBST(LIBUSB_MAJOR_VERSION)
+ AC_SUBST(LIBUSB_MINOR_VERSION)
+@@ -62,7 +63,7 @@
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
+
+ # Specify a configuration file
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS([config.h])
+
+ AC_DEFINE_UNQUOTED(LIBUSB_MAJOR_VERSION, $LIBUSB_MAJOR_VERSION)
+ AC_DEFINE_UNQUOTED(LIBUSB_MINOR_VERSION, $LIBUSB_MINOR_VERSION)
+@@ -111,13 +112,13 @@
+
+ dnl figure debugging default, prior to $ac_help setup
+ dnl
+-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
++dnl AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+ if test `expr $LIBUSB_MINOR_VERSION \% 2` = 1 ; then
+ debug_default=yes
+ else
+ debug_default=minimum
+ fi
+-AC_DIVERT_POP()dnl
++dnl AC_DIVERT_POP()dnl
+
+ dnl declare --enable-* args and collect ac_help strings
+ AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=$debug_default]],,enable_debug=$debug_default)
+@@ -175,15 +176,11 @@
+
+ if test "$os_support" = "bsd"; then
+ AC_MSG_CHECKING(if dev/usb/usb.h uses new naming convention)
+- AC_TRY_COMPILE(
+- [#include <dev/usb/usb.h>],
+- [int main(void)
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <dev/usb/usb.h>]], [[int main(void)
+ {
+ int a = ((struct usb_ctl_request *)0L)->ucr_addr;
+ return 0;
+- }],
+- [AC_MSG_RESULT(yes)],
+- [AC_MSG_RESULT(no)
++ }]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
+ AC_DEFINE(HAVE_OLD_DEV_USB_USB_H)])
+ fi
+
+@@ -214,7 +211,7 @@
+
+ AM_CONDITIONAL(BUILD_DOCS, test "$build_docs" != "no")
+
+-AC_OUTPUT([
++AC_CONFIG_FILES([
+ Makefile
+ doc/Makefile
+ libusb.spec
+@@ -223,5 +220,7 @@
+ README
+ INSTALL.libusb
+ usb.h
+-],[chmod +x libusb-config])
++])
++AC_CONFIG_COMMANDS([default],[[chmod +x libusb-config]],[[]])
++AC_OUTPUT
+