aboutsummaryrefslogtreecommitdiffstats
path: root/mysql/mysql-4.1.4a/gen_lex_hash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mysql/mysql-4.1.4a/gen_lex_hash.patch')
-rw-r--r--mysql/mysql-4.1.4a/gen_lex_hash.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/mysql/mysql-4.1.4a/gen_lex_hash.patch b/mysql/mysql-4.1.4a/gen_lex_hash.patch
index e69de29bb2..27bfc0f6a3 100644
--- a/mysql/mysql-4.1.4a/gen_lex_hash.patch
+++ b/mysql/mysql-4.1.4a/gen_lex_hash.patch
@@ -0,0 +1,21 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mysql-4.1.4a-gamma/sql/Makefile.am~gen_lex_hash
++++ mysql-4.1.4a-gamma/sql/Makefile.am
+@@ -140,9 +140,10 @@
+ @echo "If it fails, re-run configure with --with-low-memory"
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
+-lex_hash.h: lex.h gen_lex_hash.cc sql_yacc.h
+- $(MAKE) gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
++lex_hash.h: lex.h gen_lex_hash$(EXEEXT) sql_yacc.h
++ $(GEN_LEX_HASH) > $@ || rm -f $@
+
+ # Hack to ensure that lex_hash.h is built early
+ sql_lex.o: lex_hash.h