aboutsummaryrefslogtreecommitdiffstats
path: root/packages/autofs
diff options
context:
space:
mode:
Diffstat (limited to 'packages/autofs')
-rw-r--r--packages/autofs/.mtn2git_empty0
-rw-r--r--packages/autofs/autofs-4.1.4/.mtn2git_empty0
-rw-r--r--packages/autofs/autofs_4.0.0.bb17
-rw-r--r--packages/autofs/autofs_4.1.4.bb21
4 files changed, 38 insertions, 0 deletions
diff --git a/packages/autofs/.mtn2git_empty b/packages/autofs/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/autofs/.mtn2git_empty
diff --git a/packages/autofs/autofs-4.1.4/.mtn2git_empty b/packages/autofs/autofs-4.1.4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/autofs/autofs-4.1.4/.mtn2git_empty
diff --git a/packages/autofs/autofs_4.0.0.bb b/packages/autofs/autofs_4.0.0.bb
index e69de29bb2..225841172a 100644
--- a/packages/autofs/autofs_4.0.0.bb
+++ b/packages/autofs/autofs_4.0.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Kernel based automounter for linux."
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/old/autofs-${PV}-1.tar.bz2"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'INSTALLROOT=${D}' install
+}
diff --git a/packages/autofs/autofs_4.1.4.bb b/packages/autofs/autofs_4.1.4.bb
index e69de29bb2..8cb633c391 100644
--- a/packages/autofs/autofs_4.1.4.bb
+++ b/packages/autofs/autofs_4.1.4.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Kernel based automounter for linux."
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
+ ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
+ file://cross.patch;patch=1"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'INSTALLROOT=${D}' install
+}