aboutsummaryrefslogtreecommitdiffstats
path: root/packages/automake
diff options
context:
space:
mode:
Diffstat (limited to 'packages/automake')
-rw-r--r--packages/automake/automake_1.7.7.bb20
-rw-r--r--packages/automake/automake_1.8.2.bb24
-rw-r--r--packages/automake/automake_1.8.4.bb24
-rw-r--r--packages/automake/automake_1.9.2.bb27
-rw-r--r--packages/automake/automake_1.9.3.bb27
5 files changed, 122 insertions, 0 deletions
diff --git a/packages/automake/automake_1.7.7.bb b/packages/automake/automake_1.7.7.bb
index e69de29bb2..e28e79009e 100644
--- a/packages/automake/automake_1.7.7.bb
+++ b/packages/automake/automake_1.7.7.bb
@@ -0,0 +1,20 @@
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+DESCRIPTION = "A tool for automatically generating Makefiles."
+SECTION = "devel"
+LICENSE = "GPL"
+PR = "r2"
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.7 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.7 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.8.2.bb b/packages/automake/automake_1.8.2.bb
index e69de29bb2..a61ab5cc98 100644
--- a/packages/automake/automake_1.8.2.bb
+++ b/packages/automake/automake_1.8.2.bb
@@ -0,0 +1,24 @@
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
+ file://automake182-update-configscripts.patch;patch=1;pnum=1"
+DESCRIPTION = "A tool for automatically generating Makefiles."
+SECTION = "devel"
+LICENSE = "GPL"
+PR = "r2"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.8 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.8 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.8.4.bb b/packages/automake/automake_1.8.4.bb
index e69de29bb2..b0f2ab169b 100644
--- a/packages/automake/automake_1.8.4.bb
+++ b/packages/automake/automake_1.8.4.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.8 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.8 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.9.2.bb b/packages/automake/automake_1.9.2.bb
index e69de29bb2..e720475f8b 100644
--- a/packages/automake/automake_1.9.2.bb
+++ b/packages/automake/automake_1.9.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+S = "${WORKDIR}/automake-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.9.3.bb b/packages/automake/automake_1.9.3.bb
index e69de29bb2..448974e65c 100644
--- a/packages/automake/automake_1.9.3.bb
+++ b/packages/automake/automake_1.9.3.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+S = "${WORKDIR}/automake-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}