aboutsummaryrefslogtreecommitdiffstats
path: root/packages/changedfiles
diff options
context:
space:
mode:
Diffstat (limited to 'packages/changedfiles')
-rw-r--r--packages/changedfiles/.mtn2git_empty0
-rw-r--r--packages/changedfiles/changedfiles-daemon_1.0-rc1.bb14
-rw-r--r--packages/changedfiles/changedfiles.inc11
-rw-r--r--packages/changedfiles/files/.mtn2git_empty0
-rw-r--r--packages/changedfiles/files/autofoo.patch27
5 files changed, 52 insertions, 0 deletions
diff --git a/packages/changedfiles/.mtn2git_empty b/packages/changedfiles/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/changedfiles/.mtn2git_empty
diff --git a/packages/changedfiles/changedfiles-daemon_1.0-rc1.bb b/packages/changedfiles/changedfiles-daemon_1.0-rc1.bb
index e69de29bb2..a285d3dbe6 100644
--- a/packages/changedfiles/changedfiles-daemon_1.0-rc1.bb
+++ b/packages/changedfiles/changedfiles-daemon_1.0-rc1.bb
@@ -0,0 +1,14 @@
+include changedfiles.inc
+PR = "r1"
+
+SRC_URI += "file://autofoo.patch;patch=1"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake daemon
+}
+
+do_install() {
+ oe_runmake -C daemon install bindir=${D}${bindir} sysconfdir=${D}${sysconfdir}
+}
diff --git a/packages/changedfiles/changedfiles.inc b/packages/changedfiles/changedfiles.inc
index e69de29bb2..a47c821182 100644
--- a/packages/changedfiles/changedfiles.inc
+++ b/packages/changedfiles/changedfiles.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "A framework for simple filesystem replication \
+and/or security monitoring and/or automatic file transformations"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "fget"
+RDEPENDS = "fget"
+
+SRC_URI = "http://www.bangstate.com/changedfiles-${PV}.tar.gz"
+S = "${WORKDIR}/changedfiles-${PV}"
diff --git a/packages/changedfiles/files/.mtn2git_empty b/packages/changedfiles/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/changedfiles/files/.mtn2git_empty
diff --git a/packages/changedfiles/files/autofoo.patch b/packages/changedfiles/files/autofoo.patch
index e69de29bb2..d6020c7bf7 100644
--- a/packages/changedfiles/files/autofoo.patch
+++ b/packages/changedfiles/files/autofoo.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- changedfiles-1.0-rc1/configure.in~autofoo
++++ changedfiles-1.0-rc1/configure.in
+@@ -9,11 +9,14 @@
+ case "$host" in
+ alpha*-*-linux*-*) AC_DEFINE( IS_ALPHA, 1, [System is DEC alpha based] );;
+ *-linux*)
+- AC_MSG_CHECKING( linux version )
+- case `uname -r` in
+- *2.4*) AC_MSG_RESULT( [ Supported ] );;
+- *) AC_MSG_ERROR( [`uname -r` is an unsupported kernel (only version 2.4 is supported)] );;
+- esac;;
++ if test x"$cross_compiling" = "x"; then
++ AC_MSG_CHECKING( linux version )
++ case `uname -r` in
++ *2.4*) AC_MSG_RESULT( [ Supported ] );;
++ *) AC_MSG_ERROR( [`uname -r` is an unsupported kernel (only version 2.4 is supported)] );;
++ esac
++ fi
++ ;;
+ *-solaris*) AC_MSG_WARN( [Solaris port is still experimental, use at your own risk.] ); LIBS="$VAR -lfget -lsocket -lnsl";;
+ *) AC_MSG_ERROR( [$host is an unsuppored platform.] );;
+ esac