aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cyrus-imapd/cyrus-imapd_2.2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/cyrus-imapd/cyrus-imapd_2.2.12.bb')
-rw-r--r--packages/cyrus-imapd/cyrus-imapd_2.2.12.bb28
1 files changed, 15 insertions, 13 deletions
diff --git a/packages/cyrus-imapd/cyrus-imapd_2.2.12.bb b/packages/cyrus-imapd/cyrus-imapd_2.2.12.bb
index b1e6b8a257..468561d40d 100644
--- a/packages/cyrus-imapd/cyrus-imapd_2.2.12.bb
+++ b/packages/cyrus-imapd/cyrus-imapd_2.2.12.bb
@@ -1,9 +1,10 @@
SECTION = "console/network"
-DEPENDS = "cyrus-sasl db3"
-PR = "r0"
+DEPENDS = "cyrus-sasl db"
LICENSE = "BSD"
+PR = "r1"
SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${PV}.tar.gz \
+ file://install-sh \
file://autotools.patch;patch=1 \
file://tail.patch;patch=1"
@@ -15,15 +16,16 @@ EXTRA_OECONF = "--with-auth=unix \
FILES_${PN} += "${prefix}/cyrus/bin"
-BUILD_CFLAGS += " -I${S} -I${S}/et"
-#do_compile_prepend () {
-# cd lib
-# ccache arm-linux-gcc -L/home/kergoth/code/build-arm/tmp/staging/arm-linux/lib -Wl,-rpath-link,/home/kergoth/code/build-arm/tmp/staging/arm-linux/lib -o mkchartable mkchartable.o xmalloc.o assert.o
-# ${BUILD_CC} ${BUILD_CFLAGS} mkchartable.c -c -o mkchartable.o
-# ${BUILD_CC} ${BUILD_CFLAGS} xmalloc.c -c -o xmalloc.o
-# ${BUILD_CC} ${BUILD_CFLAGS} assert.c -c -o assert.o
-# ${BUILD_CC} ${BUILD_LDFLAGS} -o mkchartable mkchartable.o xmalloc.o assert.o
-# rm -f xmalloc.o assert.o mkchartable.o
-# cd ..
-#}
+# Target only, the db4 headers are in include/db4, so *prepend* this
+# directory to the search path
+TARGET_CPPFLAGS =+ "-I${STAGING_DIR}/${TARGET_SYS}/include/db4"
+# All, lib/foo.c includes <config.h> from the top level directory and
+# is natively compiled
+BUILD_CPPFLAGS += " -I${S} -I${S}/et"
+
+do_install () {
+ # This will make the -s option work somewhat portably cross
+ # platform
+ STRIPPROG="$STRIP" oe_runmake 'DESTDIR=${D}' INSTALL='sh ${WORKDIR}/install-sh' install
+}