aboutsummaryrefslogtreecommitdiffstats
path: root/packages/directfb/directfb_0.9.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/directfb/directfb_0.9.22.bb')
-rw-r--r--packages/directfb/directfb_0.9.22.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/directfb/directfb_0.9.22.bb b/packages/directfb/directfb_0.9.22.bb
index e69de29bb2..e117b90f44 100644
--- a/packages/directfb/directfb_0.9.22.bb
+++ b/packages/directfb/directfb_0.9.22.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "jpeg libpng zlib"
+PR = "r0"
+
+SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz"
+S = "${WORKDIR}/DirectFB-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-gfxdrivers=none --enable-libmpeg3=no --enable-freetype=no --enable-sdl=no"
+PARALLEL_MAKE = ""
+
+do_stage() {
+ oe_runmake 'DESTDIR=${STAGING_LIBDIR}/' install
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_directfb_append = " ${libdir}/directfb-${PV}/systems/*.so \
+ ${libdir}/directfb-${PV}/inputdrivers/*.so \
+ ${libdir}/directfb-${PV}/interfaces/*/*.so \
+ ${datadir}/directfb-${PV}"