aboutsummaryrefslogtreecommitdiffstats
path: root/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/driftnet/driftnet-nogui-0.1.6/arm.patch')
-rw-r--r--packages/driftnet/driftnet-nogui-0.1.6/arm.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/packages/driftnet/driftnet-nogui-0.1.6/arm.patch b/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
index e69de29bb2..ebb5fadd7c 100644
--- a/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
+++ b/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
@@ -0,0 +1,55 @@
+--- driftnet-0.1.6/Makefile~ 2002-07-09 19:26:41.000000000 +0000
++++ driftnet-0.1.6/Makefile 2004-10-20 21:51:48.000000000 +0000
+@@ -13,14 +13,14 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+ LDFLAGS += -g
+
+ # You might need these if libpcap is installed somewhere random.
+-CFLAGS += -I/usr/include/pcap
++#CFLAGS += -I/usr/include/pcap
+ #LDFLAGS += -L/path/to/libpcap.so
+
+ # Required on Linux to get BSDish definitions of the TCP/IP structs.
+@@ -31,14 +31,14 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++#CFLAGS += `gtk-config --cflags`
++#LDLIBS += -ljpeg -lungif `gtk-config --libs`
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+ # use this, comment out the two preceding CFLAGS and LDLIBS lines and uncomment
+ # the following line:
+-#CFLAGS += -DNO_DISPLAY_WINDOW
++CFLAGS += -DNO_DISPLAY_WINDOW
+
+ # On systems with a C99 compiler, driftnet will use <stdint.h> for the
+ # definitions of types such as uint8_t. On other systems like Solaris, these
+@@ -81,7 +81,7 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+