aboutsummaryrefslogtreecommitdiffstats
path: root/packages/efl/edje-native_0.5.0.025.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl/edje-native_0.5.0.025.bb')
-rw-r--r--packages/efl/edje-native_0.5.0.025.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/packages/efl/edje-native_0.5.0.025.bb b/packages/efl/edje-native_0.5.0.025.bb
index 5e7bed336d..5eb077922a 100644
--- a/packages/efl/edje-native_0.5.0.025.bb
+++ b/packages/efl/edje-native_0.5.0.025.bb
@@ -1,22 +1,18 @@
include edje_${PV}.bb
-PR = "r2"
-
-REAL_TARGET_SYS := ${TARGET_SYS}
+PR = "r3"
inherit native
-DEPENDS = "evas-native ecore-native eet-native embryo-native imlib2-native"
+
+DEPENDS = "evas-native ecore-native eet-native embryo-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/edje"
EXTRA_OECONF = "--with-evas-config=${STAGING_BINDIR}/evas-config-native \
--with-ecore-config=${STAGING_BINDIR}/ecore-config-native \
--with-eet-config=${STAGING_BINDIR}/eet-config-native \
- --with-embryo-config=${STAGING_BINDIR}/embryo-config-native \
- --with-imlib2-config=${STAGING_BINDIR}/imlib2-config-native "
+ --with-embryo-config=${STAGING_BINDIR}/embryo-config-native"
do_configure_prepend() {
- sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
-# sed -i 's:/usr/bin/cpp:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-cpp:' ${S}/src/bin/edje_cc_parse.c
-# sed -i 's:/usr/bin/gcc:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-gcc:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
sed -i 's:cpp -I:/usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
sed -i 's:gcc -I:/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
}