aboutsummaryrefslogtreecommitdiffstats
path: root/packages/efl/emotion_20060101.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl/emotion_20060101.bb')
-rw-r--r--packages/efl/emotion_20060101.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/efl/emotion_20060101.bb b/packages/efl/emotion_20060101.bb
new file mode 100644
index 0000000000..e450cf1d3a
--- /dev/null
+++ b/packages/efl/emotion_20060101.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Emotion is a multimedia library based on libxine"
+LICENSE = "MIT"
+DEPENDS = "eet virtual/evas edje virtual/ecore embryo virtual/libxine"
+RDEPENDS += "libemotion-themes libemotion-plugins"
+PR = "r2"
+
+#FIXME: Needs patch not to build the examples when building against ecore-fb, because the examples depend on ecore-x11
+
+inherit efl
+
+SRC_URI = "cvs://anonymous@thinktux.net/root;module=e17/libs/emotion;date=${PV}"
+S = "${WORKDIR}/emotion"
+
+PACKAGES += "emotion-plugins"
+FILES_emotion-plugins = "${libdir}/xine/plugins/1.1.0/*.so ${libdir}/emotion/*.so"
+
+do_compile_prepend() {
+ find ${S} -type f -name "*.[ch]" | xargs sed -i 's:NULL:0:g'
+} \ No newline at end of file