aboutsummaryrefslogtreecommitdiffstats
path: root/packages/embryo/embryo_0.9.1.007.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/embryo/embryo_0.9.1.007.bb')
-rw-r--r--packages/embryo/embryo_0.9.1.007.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/embryo/embryo_0.9.1.007.bb b/packages/embryo/embryo_0.9.1.007.bb
index e69de29bb2..49a1e9df4e 100644
--- a/packages/embryo/embryo_0.9.1.007.bb
+++ b/packages/embryo/embryo_0.9.1.007.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Embryo implements a C like scripting language used in various parts \
+of the Enlightenment project, namely Edje. Embryo's scripting language is based on \
+CompuPhase's Small language that was introduced in Dr Dobb's Journal in 1999. \
+Embryo allows scripting capabilities in places that otherwise wouldn't support \
+basic programming structures such as in Edje EDCs."
+SECTION = "e/libs"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/embryo-${PV}.tar.gz"
+S = "${WORKDIR}/embryo-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+do_stage () {
+ oe_libinstall -C src/lib libembryo ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/lib/Embryo.h ${STAGING_INCDIR}/
+}
+
+PACKAGES += "embryo-examples"
+
+FILES_${PN} = "${libdir}/libembryo*.so*"
+FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig"
+FILES_${PN}-examples = "${datadir}"
+