aboutsummaryrefslogtreecommitdiffstats
path: root/packages/epsilon/epsilon_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/epsilon/epsilon_cvs.bb')
-rw-r--r--packages/epsilon/epsilon_cvs.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/epsilon/epsilon_cvs.bb b/packages/epsilon/epsilon_cvs.bb
index e69de29bb2..02719d605f 100644
--- a/packages/epsilon/epsilon_cvs.bb
+++ b/packages/epsilon/epsilon_cvs.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Epsilon is a flexable and powerful image thumbnailing library \
+that is complient with the freedesktop.org Thumbnail Managing Standard. \
+Unlike Epeg, Epsilon has native support for PNG, and is built upon Imlib2 \
+making any format supported by Imlib2 such as JPEG, PNG, XCF, TIFF and GIF. \
+To provide the best possible performance Epsilon can even integrate \
+with Epeg directly to harness it's speed."
+SECTION = "e/libs"
+LICENSE = "GPL"
+DEPENDS = "epeg libpng imlib2"
+PV = "${CVSDATE}"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/libs/epsilon"
+S = "${WORKDIR}/epsilon"
+
+inherit autotools pkgconfig binconfig
+
+do_stage () {
+ oe_libinstall -C src/lib libepsilon ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/lib/Epsilon.h ${STAGING_INCDIR}/
+}