aboutsummaryrefslogtreecommitdiffstats
path: root/packages/etox
diff options
context:
space:
mode:
Diffstat (limited to 'packages/etox')
-rw-r--r--packages/etox/.mtn2git_empty0
-rw-r--r--packages/etox/etox_0.9.0.003.bb23
2 files changed, 23 insertions, 0 deletions
diff --git a/packages/etox/.mtn2git_empty b/packages/etox/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/etox/.mtn2git_empty
diff --git a/packages/etox/etox_0.9.0.003.bb b/packages/etox/etox_0.9.0.003.bb
index e69de29bb2..e986212a8d 100644
--- a/packages/etox/etox_0.9.0.003.bb
+++ b/packages/etox/etox_0.9.0.003.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Etox is a type setting and text layout library based on Evas. \
+Etox helps you when it comes to displaying, moving, resizing, layering, \
+clipping, aligning and coloring fonts in different styles, and more."
+SECTION = "e/libs"
+DEPENDS = "edb evas ecore"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/etox-${PV}.tar.gz"
+S = "${WORKDIR}/etox-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+do_stage () {
+ oe_libinstall -C src libetox ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/Etox.h ${STAGING_INCDIR}/
+}
+
+PACKAGES += "etox-examples"
+
+FILES_${PN} = "${libdir}/libetox*.so*"
+FILES_${PN}-dev += "${bindir}/etox-config ${libdir}/pkgconfig"
+FILES_${PN}-examples = "${bindir}/etox* ${datadir}"