aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fam/fam_2.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/fam/fam_2.7.0.bb')
-rw-r--r--packages/fam/fam_2.7.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/fam/fam_2.7.0.bb b/packages/fam/fam_2.7.0.bb
index e69de29bb2..b3265bbd96 100644
--- a/packages/fam/fam_2.7.0.bb
+++ b/packages/fam/fam_2.7.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "File Alteration Monitor"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "ftp://oss.sgi.com/projects/fam/download/stable/fam-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+
+inherit autotools
+
+CPPFLAGS_append = " -DNDEBUG"
+
+do_stage() {
+ oe_libinstall -so -a -C lib libfam ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/fam.h ${STAGING_INCDIR}/
+}
+