aboutsummaryrefslogtreecommitdiffstats
path: root/packages/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/fso-abyss_git.bb23
-rw-r--r--packages/freesmartphone/libgsm0710mux/abyss.conf (renamed from packages/freesmartphone/fso-abyss/abyss.conf)0
-rw-r--r--packages/freesmartphone/libgsm0710mux/om-gta01/abyss.conf (renamed from packages/freesmartphone/fso-abyss/om-gta01/abyss.conf)0
-rw-r--r--packages/freesmartphone/libgsm0710mux/om-gta02/abyss.conf (renamed from packages/freesmartphone/fso-abyss/om-gta02/abyss.conf)0
-rw-r--r--packages/freesmartphone/libgsm0710mux/om-gta03/abyss.conf (renamed from packages/freesmartphone/fso-abyss/om-gta03/abyss.conf)0
-rw-r--r--packages/freesmartphone/libgsm0710mux_git.bb38
6 files changed, 39 insertions, 22 deletions
diff --git a/packages/freesmartphone/fso-abyss_git.bb b/packages/freesmartphone/fso-abyss_git.bb
index 20f68c0ad0..e8e9489a15 100644
--- a/packages/freesmartphone/fso-abyss_git.bb
+++ b/packages/freesmartphone/fso-abyss_git.bb
@@ -2,35 +2,14 @@ DESCRIPTION = "Abyss is a GSM 07.10 muxer userspace daemon"
HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/Abyss"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
-DEPENDS = "vala-native dbus dbus-glib libgsm0710"
+DEPENDS = "vala-native dbus dbus-glib libgsm0710mux"
LICENSE = "GPL"
PV = "0.3.1+gitr${SRCREV}"
PR = "r0"
SRC_URI = "\
${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
- file://abyss.conf \
"
S = "${WORKDIR}/git"
inherit autotools
-
-do_install_append() {
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
-}
-
-PACKAGES =+ "${PN}-config"
-
-FILES_${PN} += "${sysconfdir} ${datadir}"
-RRECOMMENDS_${PN} = "${PN}-config"
-
-FILES_${PN}-config = "\
- ${sysconfdir}/abyss.conf \
-"
-
-CONFFILES_${PN}-config = "\
- ${sysconfdir}/abyss.conf \
-"
-
-PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
diff --git a/packages/freesmartphone/fso-abyss/abyss.conf b/packages/freesmartphone/libgsm0710mux/abyss.conf
index e69de29bb2..e69de29bb2 100644
--- a/packages/freesmartphone/fso-abyss/abyss.conf
+++ b/packages/freesmartphone/libgsm0710mux/abyss.conf
diff --git a/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf b/packages/freesmartphone/libgsm0710mux/om-gta01/abyss.conf
index 67da210396..67da210396 100644
--- a/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf
+++ b/packages/freesmartphone/libgsm0710mux/om-gta01/abyss.conf
diff --git a/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf b/packages/freesmartphone/libgsm0710mux/om-gta02/abyss.conf
index 67da210396..67da210396 100644
--- a/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf
+++ b/packages/freesmartphone/libgsm0710mux/om-gta02/abyss.conf
diff --git a/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf b/packages/freesmartphone/libgsm0710mux/om-gta03/abyss.conf
index 1764c5b798..1764c5b798 100644
--- a/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf
+++ b/packages/freesmartphone/libgsm0710mux/om-gta03/abyss.conf
diff --git a/packages/freesmartphone/libgsm0710mux_git.bb b/packages/freesmartphone/libgsm0710mux_git.bb
new file mode 100644
index 0000000000..3a4c0d9339
--- /dev/null
+++ b/packages/freesmartphone/libgsm0710mux_git.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "A GSM 07.10 Multiplexing Engine"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+LICENSE = "GPL"
+SECTION = "devel"
+DEPENDS = "libgsm0710 vala-native glib-2.0"
+PV = "0.3.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/libgsm0710mux;protocol=git;branch=master \
+ file://abyss.conf \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools_stage pkgconfig
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
+}
+
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+# ship vapi file
+FILES_${PN}-dev += "${datadir}/vala"
+
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"