aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fuse/fuse-module_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/fuse/fuse-module_2.4.2.bb')
-rw-r--r--packages/fuse/fuse-module_2.4.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/fuse/fuse-module_2.4.2.bb b/packages/fuse/fuse-module_2.4.2.bb
new file mode 100644
index 0000000000..616b898667
--- /dev/null
+++ b/packages/fuse/fuse-module_2.4.2.bb
@@ -0,0 +1,33 @@
+HOMEPAGE = "http://fuse.sf.net"
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE = "GPL
+
+
+DEPENDS = "fakeroot-native"
+RRECOMMEND = "fuse"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz"
+S = "${WORKDIR}/fuse-${PV}"
+
+inherit autotools pkgconfig module
+EXTRA_OECONF = " --with-kernel=${STAGING_KERNEL_DIR}"
+
+do_configure() {
+cd ${S} ; oe_runconf
+}
+
+do_compile(){
+LDFLAGS=""
+cd ${S}/kernel
+oe_runmake
+}
+
+fakeroot do_install() {
+LDFLAGS=""
+cd ${S}/kernel
+oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} = "/dev /lib/modules"