aboutsummaryrefslogtreecommitdiffstats
path: root/packages/galculator/galculator-1.2.3
diff options
context:
space:
mode:
Diffstat (limited to 'packages/galculator/galculator-1.2.3')
-rw-r--r--packages/galculator/galculator-1.2.3/.mtn2git_empty0
-rw-r--r--packages/galculator/galculator-1.2.3/Makefile.am.patch14
-rw-r--r--packages/galculator/galculator-1.2.3/desktop-categories.patch10
-rw-r--r--packages/galculator/galculator-1.2.3/src-ui.c.patch11
4 files changed, 35 insertions, 0 deletions
diff --git a/packages/galculator/galculator-1.2.3/.mtn2git_empty b/packages/galculator/galculator-1.2.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/galculator/galculator-1.2.3/.mtn2git_empty
diff --git a/packages/galculator/galculator-1.2.3/Makefile.am.patch b/packages/galculator/galculator-1.2.3/Makefile.am.patch
index e69de29bb2..d39b5ea902 100644
--- a/packages/galculator/galculator-1.2.3/Makefile.am.patch
+++ b/packages/galculator/galculator-1.2.3/Makefile.am.patch
@@ -0,0 +1,14 @@
+--- galculator-1.2.3/src/Makefile.am 2004-03-20 19:58:18.000000000 +0100
++++ galculator-1.2.3-oe/src/Makefile.am 2004-05-26 15:35:46.000000000 +0200
+@@ -1,9 +1,8 @@
+ ## Process this file with automake to produce Makefile.in
+ # -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+-# \
++#
+
+-INCLUDES = \
+- -DPACKAGE_LOCALE_DIR=\""$(datadir)/locale"\" \
++INCLUDES = -DPACKAGE_LOCALE_DIR=\""$(datadir)/locale"\" \
+ -DPACKAGE_GLADE_DIR=\""$(datadir)/galculator/glade"\" \
+ @PACKAGE_CFLAGS@
+
diff --git a/packages/galculator/galculator-1.2.3/desktop-categories.patch b/packages/galculator/galculator-1.2.3/desktop-categories.patch
index e69de29bb2..160932d026 100644
--- a/packages/galculator/galculator-1.2.3/desktop-categories.patch
+++ b/packages/galculator/galculator-1.2.3/desktop-categories.patch
@@ -0,0 +1,10 @@
+--- galculator-1.2.3/galculator.desktop.in.old 2004-08-03 15:41:54.000000000 +0100
++++ galculator-1.2.3/galculator.desktop.in 2004-08-03 15:42:00.000000000 +0100
+@@ -5,6 +5,6 @@
+ Icon=gnome-calc2.png
+ Terminal=false
+ Type=Application
+-Categories=Application;Utility;
++Categories=Application;Utility;Office;
+ StartupNotify=true
+ Encoding=UTF-8
diff --git a/packages/galculator/galculator-1.2.3/src-ui.c.patch b/packages/galculator/galculator-1.2.3/src-ui.c.patch
index e69de29bb2..7da341a39b 100644
--- a/packages/galculator/galculator-1.2.3/src-ui.c.patch
+++ b/packages/galculator/galculator-1.2.3/src-ui.c.patch
@@ -0,0 +1,11 @@
+--- src/ui.c.orig 2004-08-09 17:26:37.000000000 +0200
++++ src/ui.c 2004-08-09 17:22:02.000000000 +0200
+@@ -582,7 +582,7 @@
+ /* just put one here and hide it afterwards. we need the button
+ for working key accelerators. */
+ if (prefs.mode == BASIC_MODE)
+- ui_main_window_set_dispctrl (DISPCTRL_BOTTOM);
++ ui_main_window_set_dispctrl (DISPCTRL_RIGHT);
+ else if (current_status.notation == CS_RPN)
+ ui_main_window_set_dispctrl (DISPCTRL_RIGHTV);
+ else ui_main_window_set_dispctrl (DISPCTRL_RIGHT);