aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gammu
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gammu')
-rw-r--r--packages/gammu/gammu_1.20.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/gammu/gammu_1.20.0.bb b/packages/gammu/gammu_1.20.0.bb
index 617648c0a0..6cc864498a 100644
--- a/packages/gammu/gammu_1.20.0.bb
+++ b/packages/gammu/gammu_1.20.0.bb
@@ -18,6 +18,13 @@ do_stage() {
autotools_stage_all
}
+# gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
+# Replace it by custom do_stage_append():
+do_stage_append () {
+ install -d ${PKG_CONFIG_DIR}
+ cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
+}
+
PACKAGES =+ "libgammu"
FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker"