aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc/gcc-cross_csl-arm-20050603.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc/gcc-cross_csl-arm-20050603.bb')
-rw-r--r--packages/gcc/gcc-cross_csl-arm-20050603.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_csl-arm-20050603.bb b/packages/gcc/gcc-cross_csl-arm-20050603.bb
index e69de29bb2..e815b2f9e3 100644
--- a/packages/gcc/gcc-cross_csl-arm-20050603.bb
+++ b/packages/gcc/gcc-cross_csl-arm-20050603.bb
@@ -0,0 +1,15 @@
+include gcc_csl-arm-20050603.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r0"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-cross-build.inc
+# cross packaging
+include gcc-package-cross.inc