aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gdal/gdal_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gdal/gdal_1.5.2.bb')
-rw-r--r--packages/gdal/gdal_1.5.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gdal/gdal_1.5.2.bb b/packages/gdal/gdal_1.5.2.bb
new file mode 100644
index 0000000000..60162e15f5
--- /dev/null
+++ b/packages/gdal/gdal_1.5.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "proj-4 sqlite3 zlib jpeg libpng jasper expat"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=${STAGING_DIR_TARGET} \
+ --with-png=${STAGING_DIR_TARGET} \
+ --with-jpeg=${STAGING_DIR_TARGET} \
+ --with-jasper=${STAGING_DIR_TARGET} \
+ --with-libtiff=${STAGING_DIR_TARGET} \
+ --with-expat=${STAGING_DIR_TARGET} \
+ --with-expat-inc=${STAGING_INCDIR} \
+ --with-expat-lib=${STAGING_LIBDIR} \
+"
+
+# GDAL clutter /usr/share with files instead of using a subdir :(
+FILES_${PN} += "${datadir}"
+
+do_stage() {
+ autotools_stage_all
+}
+