aboutsummaryrefslogtreecommitdiffstats
path: root/packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch')
-rw-r--r--packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch b/packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch
index e69de29bb2..4029bf4f2a 100644
--- a/packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch
+++ b/packages/glibc/glibc-2.2.5/glibc-2.2.5-crosstest.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- glibc-2.2.5/dlfcn/Makefile~glibc-2.2.5-crosstest.patch 2004-09-03 19:00:33.000000000 -0500
++++ glibc-2.2.5/dlfcn/Makefile 2004-09-03 19:00:38.000000000 -0500
+@@ -60,6 +60,8 @@
+ test-modules = $(addprefix $(objpfx),$(addsuffix .so,$(modules-names)))
+ $(test-modules): $(objpfx)%.so: $(objpfx)%.os
+ $(build-module)
++# without following rule, test-modules don't get built when cross-compiling
++tests: $(test-modules)
+
+ $(objpfx)glrefmain: $(libdl)
+ $(objpfx)glrefmain.out: $(objpfx)glrefmain \
+--- glibc-2.2.5/elf/Makefile~glibc-2.2.5-crosstest.patch 2004-09-03 19:00:33.000000000 -0500
++++ glibc-2.2.5/elf/Makefile 2004-09-03 19:00:38.000000000 -0500
+@@ -263,6 +263,9 @@
+ test-modules = $(addprefix $(objpfx),$(addsuffix .so,$(strip $(modules-names))))
+ generated += $(addsuffix .so,$(strip $(modules-names)))
+
++# without following rule, test-modules don't get built when cross-compiling
++tests: $(test-modules)
++
+ ifeq (yes,$(build-shared))
+ ifeq ($(cross-compiling),no)
+ tests: $(objpfx)tst-pathopt.out