aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome/metacity_2.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnome/metacity_2.24.0.bb')
-rw-r--r--packages/gnome/metacity_2.24.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/gnome/metacity_2.24.0.bb b/packages/gnome/metacity_2.24.0.bb
new file mode 100644
index 0000000000..e978064879
--- /dev/null
+++ b/packages/gnome/metacity_2.24.0.bb
@@ -0,0 +1,20 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Metacity is the boring window manager for the adult in you."
+LICENSE = "GPL"
+DEPENDS = "libwnck startup-notification gtk+ gconf gdk-pixbuf-csource-native"
+
+inherit gnome update-alternatives
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/metacity"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF += "--disable-verbose \
+ --disable-xinerama"
+
+FILES_${PN} += "${datadir}/themes ${datadir}/gnome*"
+
+do_stage () {
+ autotools_stage_all
+}