aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gnome-panel_2.24.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gnome/gnome-panel_2.24.0.bb b/packages/gnome/gnome-panel_2.24.0.bb
new file mode 100644
index 0000000000..b96d985387
--- /dev/null
+++ b/packages/gnome/gnome-panel_2.24.0.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL"
+DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_stage() {
+ autotools_stage_all
+}