aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnuplot/qtplot_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnuplot/qtplot_0.2.bb')
-rw-r--r--packages/gnuplot/qtplot_0.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/gnuplot/qtplot_0.2.bb b/packages/gnuplot/qtplot_0.2.bb
index e69de29bb2..0f7ddf1937 100644
--- a/packages/gnuplot/qtplot_0.2.bb
+++ b/packages/gnuplot/qtplot_0.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "QT Gnuplot is a front end for Gnuplot. Install Opie-Embedded \
+console to enable the Launch Gnuplot menu option."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "Philip Frampton"
+LICENSE = "GPL"
+PRIORITY = "optional"
+
+DEPENDS = "gnuplot"
+RDEPDENDS = "gnuplot"
+
+HOMEPAGE = "http://www.mneuroth.de/privat/zaurus/gnuplot.html"
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qtplot-${PV}.tar.gz"
+
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+inherit opie
+
+do_install_prepend() {
+ install -d ${D}${palmtopdir}/pics
+ install -d ${D}${palmtopdir}/help/html
+
+ install -m 644 Qtplot.png ${D}${palmtopdir}/pics/
+ install -m 644 qtplot.html ${D}${palmtopdir}/help/html/
+}