aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-beam
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-beam')
-rw-r--r--packages/gpe-beam/.mtn2git_empty0
-rw-r--r--packages/gpe-beam/gpe-beam-0.2.6/.mtn2git_empty0
-rw-r--r--packages/gpe-beam/gpe-beam-0.2.6/vcard-send.patch33
-rw-r--r--packages/gpe-beam/gpe-beam_0.2.6.bb13
-rw-r--r--packages/gpe-beam/gpe-beam_0.2.7.bb12
5 files changed, 58 insertions, 0 deletions
diff --git a/packages/gpe-beam/.mtn2git_empty b/packages/gpe-beam/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-beam/.mtn2git_empty
diff --git a/packages/gpe-beam/gpe-beam-0.2.6/.mtn2git_empty b/packages/gpe-beam/gpe-beam-0.2.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-beam/gpe-beam-0.2.6/.mtn2git_empty
diff --git a/packages/gpe-beam/gpe-beam-0.2.6/vcard-send.patch b/packages/gpe-beam/gpe-beam-0.2.6/vcard-send.patch
index e69de29bb2..1a2c66f821 100644
--- a/packages/gpe-beam/gpe-beam-0.2.6/vcard-send.patch
+++ b/packages/gpe-beam/gpe-beam-0.2.6/vcard-send.patch
@@ -0,0 +1,33 @@
+Index: main.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-beam/main.c,v
+retrieving revision 1.26
+diff -u -r1.26 main.c
+--- main.c 16 Oct 2004 12:17:51 -0000 1.26
++++ main.c 17 Oct 2004 12:43:16 -0000
+@@ -632,7 +632,7 @@
+
+
+ static void
+-send_vcard (void)
++do_send_vcard (void)
+ {
+ if (!radio_is_on)
+ radio_on ();
+@@ -651,6 +651,16 @@
+ }
+ }
+
++static void
++send_vcard (void)
++{
++ scan_thread =
++ g_thread_create ((GThreadFunc)
++ do_send_vcard, NULL, FALSE, NULL);
++ if (scan_thread == NULL)
++ gpe_perror_box (_("Unable to start sender."));
++}
++
+
+ static gboolean
+ get_irstatus (void)
diff --git a/packages/gpe-beam/gpe-beam_0.2.6.bb b/packages/gpe-beam/gpe-beam_0.2.6.bb
index e69de29bb2..232234a77f 100644
--- a/packages/gpe-beam/gpe-beam_0.2.6.bb
+++ b/packages/gpe-beam/gpe-beam_0.2.6.bb
@@ -0,0 +1,13 @@
+PR = "r1"
+
+inherit gpe
+
+DESCRIPTION = "GPE infrared communication applet"
+DEPENDS = "gtk+ libgpewidget libmimedir libgpevtype openobex irda-utils dbus"
+RDEPENDS = "libopenobex-1.0-1 irda-utils"
+SECTION = "gpe"
+PRIORITY = "optional"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+LICENSE = "GPL"
+
+SRC_URI += "file://vcard-send.patch;patch=1;pnum=0"
diff --git a/packages/gpe-beam/gpe-beam_0.2.7.bb b/packages/gpe-beam/gpe-beam_0.2.7.bb
index e69de29bb2..d55cd6db60 100644
--- a/packages/gpe-beam/gpe-beam_0.2.7.bb
+++ b/packages/gpe-beam/gpe-beam_0.2.7.bb
@@ -0,0 +1,12 @@
+PR = "r0"
+
+inherit gpe
+
+DESCRIPTION = "GPE infrared communication applet"
+DEPENDS = "gtk+ libgpewidget libmimedir libgpevtype openobex irda-utils dbus"
+RDEPENDS = "libopenobex-1.0-1 irda-utils"
+SECTION = "gpe"
+PRIORITY = "optional"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+LICENSE = "GPL"
+