aboutsummaryrefslogtreecommitdiffstats
path: root/packages/groff/groff_1.19.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/groff/groff_1.19.2.bb')
-rw-r--r--packages/groff/groff_1.19.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/groff/groff_1.19.2.bb b/packages/groff/groff_1.19.2.bb
new file mode 100644
index 0000000000..7381bb3687
--- /dev/null
+++ b/packages/groff/groff_1.19.2.bb
@@ -0,0 +1,23 @@
+LICENSE = "GPL"
+SECTION = "base"
+DESCRIPTION = "GNU roff"
+RDEPENDS="libstdc++6"
+MAINTAINER = "Inge Arnesen <inge.arnesen@gmail.com>"
+SRC_URI = "http://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
+ file://Makefile.in.patch;patch=1 \
+ file://Makefile.sub.patch;patch=1 \
+ file://groff.patch;patch=1"
+
+# prefix and exec-prefix are broken and the .in file is broken too
+# and can't be autoreconf'ed, so specify every dir
+EXTRA_OECONF="--prefix=${D} --exec-prefix=${D} --bindir=${D}/usr/bin --datadir=${D}/usr/share --mandir=${D}/usr/man --infodir=${D}/usr/share/info"
+inherit autotools
+
+do_configure () {
+ oe_runconf
+}
+
+#do_install() {
+# oe_runmake 'PREFIX=${D}' install
+#}
+