aboutsummaryrefslogtreecommitdiffstats
path: root/packages/grub/grub_0.93.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/grub/grub_0.93.bb')
-rw-r--r--packages/grub/grub_0.93.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/grub/grub_0.93.bb b/packages/grub/grub_0.93.bb
index e69de29bb2..d67247ccff 100644
--- a/packages/grub/grub_0.93.bb
+++ b/packages/grub/grub_0.93.bb
@@ -0,0 +1,18 @@
+SECTION = "base"
+DESCRIPTION = "grand unified bootloader"
+
+SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \
+ file://autohell.patch;patch=1 \
+ file://memcpy.patch;patch=1 \
+ file://reiserfs.patch;patch=1"
+
+S = "${WORKDIR}/grub-${PV}"
+
+inherit autotools
+
+python __anonymous () {
+ import re
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ if not re.match('i.86.*-linux', host):
+ raise bb.parse.SkipPackage("incompatible with host %s" % host)
+}