aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+/gtk+-2.8.9
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gtk+/gtk+-2.8.9')
-rw-r--r--packages/gtk+/gtk+-2.8.9/automake-lossage.patch24
-rw-r--r--packages/gtk+/gtk+-2.8.9/disable-tooltips.patch11
-rw-r--r--packages/gtk+/gtk+-2.8.9/gtk+-handhelds.patch264
-rw-r--r--packages/gtk+/gtk+-2.8.9/hardcoded_libtool.patch29
-rw-r--r--packages/gtk+/gtk+-2.8.9/menu-deactivate.patch50
-rw-r--r--packages/gtk+/gtk+-2.8.9/no-demos.patch10
-rw-r--r--packages/gtk+/gtk+-2.8.9/no-xwc.patch151
-rw-r--r--packages/gtk+/gtk+-2.8.9/scroll-timings.patch15
-rw-r--r--packages/gtk+/gtk+-2.8.9/single-click.patch36
-rw-r--r--packages/gtk+/gtk+-2.8.9/small-gtkfilesel.patch267
-rw-r--r--packages/gtk+/gtk+-2.8.9/spinbutton.patch128
11 files changed, 0 insertions, 985 deletions
diff --git a/packages/gtk+/gtk+-2.8.9/automake-lossage.patch b/packages/gtk+/gtk+-2.8.9/automake-lossage.patch
deleted file mode 100644
index 0d423ddbb9..0000000000
--- a/packages/gtk+/gtk+-2.8.9/automake-lossage.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- gtk+-2.4.1/docs/tutorial/Makefile.am~ 2003-05-06 22:54:20.000000000 +0100
-+++ gtk+-2.4.1/docs/tutorial/Makefile.am 2004-05-08 12:31:41.000000000 +0100
-@@ -52,21 +52,5 @@
-
- dist-hook: html
- cp -Rp $(srcdir)/html $(distdir)
--else
--html:
-- echo "***"
-- echo "*** Warning: Tutorial not built"
-- echo "***"
--
--pdf:
-- echo "***"
-- echo "*** Warning: Tutorial not built"
-- echo "***"
--
--dist-hook:
-- echo "***"
-- echo "*** Warning: Tutorial not built"
-- echo "*** DISTRIBUTION IS INCOMPLETE"
-- echo "***"
- endif
-
diff --git a/packages/gtk+/gtk+-2.8.9/disable-tooltips.patch b/packages/gtk+/gtk+-2.8.9/disable-tooltips.patch
deleted file mode 100644
index d71d839c3c..0000000000
--- a/packages/gtk+/gtk+-2.8.9/disable-tooltips.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gtk+-2.4.3/gtk/gtktooltips.c.old 2004-07-04 18:52:04.000000000 +0100
-+++ gtk+-2.4.3/gtk/gtktooltips.c 2004-07-04 18:52:08.000000000 +0100
-@@ -118,7 +118,7 @@
- tooltips->tips_data_list = NULL;
-
- tooltips->delay = DEFAULT_DELAY;
-- tooltips->enabled = TRUE;
-+ tooltips->enabled = FALSE;
- tooltips->timer_tag = 0;
- tooltips->use_sticky_delay = FALSE;
- tooltips->last_popdown.tv_sec = -1;
diff --git a/packages/gtk+/gtk+-2.8.9/gtk+-handhelds.patch b/packages/gtk+/gtk+-2.8.9/gtk+-handhelds.patch
deleted file mode 100644
index 4b97373f32..0000000000
--- a/packages/gtk+/gtk+-2.8.9/gtk+-handhelds.patch
+++ /dev/null
@@ -1,264 +0,0 @@
---- gtk+-2.8.6/gtk/gtkrange.c.orig 2005-12-07 21:13:33 +0100
-+++ gtk+-2.8.6/gtk/gtkrange.c 2005-12-07 21:21:12 +0100
-@@ -186,6 +186,7 @@
- static GtkWidgetClass *parent_class = NULL;
- static guint signals[LAST_SIGNAL];
-
-+static GdkAtom recognize_protocols_atom, atom_atom;
-
- GType
- gtk_range_get_type (void)
-@@ -226,6 +227,9 @@
- object_class = (GtkObjectClass*) class;
- widget_class = (GtkWidgetClass*) class;
-
-+ recognize_protocols_atom = gdk_atom_intern ("RECOGNIZE_PROTOCOLS", FALSE);
-+ atom_atom = gdk_atom_intern ("ATOM", FALSE);
-+
- parent_class = g_type_class_peek_parent (class);
-
- gobject_class->set_property = gtk_range_set_property;
-@@ -860,6 +864,12 @@
- &attributes, attributes_mask);
- gdk_window_set_user_data (range->event_window, range);
-
-+ gdk_property_change (range->event_window,
-+ recognize_protocols_atom,
-+ atom_atom,
-+ 32, GDK_PROP_MODE_REPLACE,
-+ NULL, 0);
-+
- widget->style = gtk_style_attach (widget->style, widget->window);
- }
-
-@@ -1229,7 +1239,7 @@
-
- /* ignore presses when we're already doing something else. */
- if (range->layout->grab_location != MOUSE_OUTSIDE)
-- return FALSE;
-+ return TRUE;
-
- range->layout->mouse_x = event->x;
- range->layout->mouse_y = event->y;
-@@ -1429,7 +1439,7 @@
- return TRUE;
- }
-
-- return FALSE;
-+ return TRUE;
- }
-
- /**
---- gtk+-2.8.6/gtk/gtkentry.c.orig 2005-09-02 21:51:06 +0200
-+++ gtk+-2.8.6/gtk/gtkentry.c 2005-12-07 21:21:12 +0100
-@@ -597,6 +597,15 @@
- 0.0,
- GTK_PARAM_READWRITE));
-
-+ gtk_widget_class_install_style_property (widget_class,
-+ g_param_spec_int ("min_width",
-+ _("Minimum width"),
-+ _("Minimum width of the entry field"),
-+ 0,
-+ G_MAXINT,
-+ MIN_ENTRY_WIDTH,
-+ G_PARAM_READABLE));
-+
- signals[POPULATE_POPUP] =
- g_signal_new ("populate_popup",
- G_OBJECT_CLASS_TYPE (gobject_class),
-@@ -1227,7 +1236,7 @@
- {
- GtkEntry *entry = GTK_ENTRY (widget);
- PangoFontMetrics *metrics;
-- gint xborder, yborder;
-+ gint xborder, yborder, min_width;
- PangoContext *context;
-
- gtk_widget_ensure_style (widget);
-@@ -1243,9 +1252,11 @@
-
- xborder += INNER_BORDER;
- yborder += INNER_BORDER;
--
-+
-+ gtk_widget_style_get (widget, "min_width", &min_width, NULL);
-+
- if (entry->width_chars < 0)
-- requisition->width = MIN_ENTRY_WIDTH + xborder * 2;
-+ requisition->width = min_width + xborder * 2;
- else
- {
- gint char_width = pango_font_metrics_get_approximate_char_width (metrics);
---- gtk+-2.8.6/gtk/gtkarrow.c.orig 2005-06-21 17:38:39 +0200
-+++ gtk+-2.8.6/gtk/gtkarrow.c 2005-12-07 21:21:12 +0100
-@@ -31,7 +31,7 @@
- #include "gtkintl.h"
- #include "gtkalias.h"
-
--#define MIN_ARROW_SIZE 15
-+#define MIN_ARROW_SIZE 7
-
- enum {
- PROP_0,
-@@ -55,6 +55,8 @@
- guint prop_id,
- GValue *value,
- GParamSpec *pspec);
-+static void gtk_arrow_size_request (GtkWidget *arrow,
-+ GtkRequisition *requisition);
-
- GType
- gtk_arrow_get_type (void)
-@@ -113,6 +115,7 @@
- GTK_PARAM_READWRITE));
-
- widget_class->expose_event = gtk_arrow_expose;
-+ widget_class->size_request = gtk_arrow_size_request;
- }
-
- static void
-@@ -168,13 +171,18 @@
- }
-
- static void
-+gtk_arrow_size_request (GtkWidget *arrow,
-+ GtkRequisition *requisition)
-+{
-+ requisition->width = MIN_ARROW_SIZE + GTK_MISC (arrow)->xpad * 2;
-+ requisition->height = MIN_ARROW_SIZE + GTK_MISC (arrow)->ypad * 2;
-+}
-+
-+static void
- gtk_arrow_init (GtkArrow *arrow)
- {
- GTK_WIDGET_SET_FLAGS (arrow, GTK_NO_WINDOW);
-
-- GTK_WIDGET (arrow)->requisition.width = MIN_ARROW_SIZE + GTK_MISC (arrow)->xpad * 2;
-- GTK_WIDGET (arrow)->requisition.height = MIN_ARROW_SIZE + GTK_MISC (arrow)->ypad * 2;
--
- arrow->arrow_type = GTK_ARROW_RIGHT;
- arrow->shadow_type = GTK_SHADOW_OUT;
- }
---- gtk+-2.8.6/gtk/gtkcalendar.c.orig 2005-12-07 21:36:14 +0100
-+++ gtk+-2.8.6/gtk/gtkcalendar.c 2005-12-07 21:49:21 +0100
-@@ -692,6 +692,35 @@
- ****************************************/
-
- static void
-+calendar_select_day (GtkCalendar *calendar, guint day)
-+{
-+ g_return_if_fail (GTK_IS_CALENDAR (calendar));
-+ g_return_if_fail (day <= 31);
-+
-+ /* Deselect the old day */
-+ if (calendar->selected_day > 0)
-+ {
-+ gint selected_day;
-+
-+ selected_day = calendar->selected_day;
-+ calendar->selected_day = 0;
-+ if (GTK_WIDGET_DRAWABLE (GTK_WIDGET (calendar)))
-+ calendar_invalidate_day_num (calendar, selected_day);
-+ }
-+
-+ calendar->selected_day = day;
-+
-+ /* Select the new day */
-+ if (day != 0)
-+ {
-+ if (GTK_WIDGET_DRAWABLE (GTK_WIDGET (calendar)))
-+ calendar_invalidate_day_num (calendar, day);
-+ }
-+
-+ g_object_notify (G_OBJECT (calendar), "day");
-+}
-+
-+static void
- calendar_set_month_next (GtkCalendar *calendar)
- {
- gint month_len;
-@@ -723,10 +752,10 @@
- if (month_len < calendar->selected_day)
- {
- calendar->selected_day = 0;
-- gtk_calendar_select_day (calendar, month_len);
-+ calendar_select_day (calendar, month_len);
- }
- else
-- gtk_calendar_select_day (calendar, calendar->selected_day);
-+ calendar_select_day (calendar, calendar->selected_day);
-
- gtk_widget_queue_draw (GTK_WIDGET (calendar));
- }
-@@ -752,10 +781,10 @@
- if (month_len < calendar->selected_day)
- {
- calendar->selected_day = 0;
-- gtk_calendar_select_day (calendar, month_len);
-+ calendar_select_day (calendar, month_len);
- }
- else
-- gtk_calendar_select_day (calendar, calendar->selected_day);
-+ calendar_select_day (calendar, calendar->selected_day);
-
- gtk_widget_queue_draw (GTK_WIDGET (calendar));
- }
-@@ -784,10 +813,10 @@
- if (month_len < calendar->selected_day)
- {
- calendar->selected_day = 0;
-- gtk_calendar_select_day (calendar, month_len);
-+ calendar_select_day (calendar, month_len);
- }
- else
-- gtk_calendar_select_day (calendar, calendar->selected_day);
-+ calendar_select_day (calendar, calendar->selected_day);
-
- gtk_widget_queue_draw (GTK_WIDGET (calendar));
- }
-@@ -1088,13 +1117,13 @@
- if (month_len < calendar->selected_day)
- {
- calendar->selected_day = 0;
-- gtk_calendar_select_day (calendar, month_len);
-+ calendar_select_day (calendar, month_len);
- }
- else
- {
- if (calendar->selected_day < 0)
- calendar->selected_day = calendar->selected_day + 1 + month_length[leap (calendar->year)][calendar->month + 1];
-- gtk_calendar_select_day (calendar, calendar->selected_day);
-+ calendar_select_day (calendar, calendar->selected_day);
- }
-
- gtk_widget_queue_draw (GTK_WIDGET (calendar));
-@@ -3285,27 +3314,7 @@
- g_return_if_fail (GTK_IS_CALENDAR (calendar));
- g_return_if_fail (day <= 31);
-
-- /* Deselect the old day */
-- if (calendar->selected_day > 0)
-- {
-- gint selected_day;
--
-- selected_day = calendar->selected_day;
-- calendar->selected_day = 0;
-- if (GTK_WIDGET_DRAWABLE (GTK_WIDGET (calendar)))
-- calendar_invalidate_day_num (calendar, selected_day);
-- }
--
-- calendar->selected_day = day;
--
-- /* Select the new day */
-- if (day != 0)
-- {
-- if (GTK_WIDGET_DRAWABLE (GTK_WIDGET (calendar)))
-- calendar_invalidate_day_num (calendar, day);
-- }
--
-- g_object_notify (G_OBJECT (calendar), "day");
-+ calendar_select_day (calendar, day);
-
- g_signal_emit (calendar,
- gtk_calendar_signals[DAY_SELECTED_SIGNAL],
diff --git a/packages/gtk+/gtk+-2.8.9/hardcoded_libtool.patch b/packages/gtk+/gtk+-2.8.9/hardcoded_libtool.patch
deleted file mode 100644
index b2afddcc61..0000000000
--- a/packages/gtk+/gtk+-2.8.9/hardcoded_libtool.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- gtk+-2.6.0/configure.in.old 2005-01-01 16:23:45.000000000 +0000
-+++ gtk+-2.6.0/configure.in 2005-01-01 16:24:03.000000000 +0000
-@@ -360,7 +360,7 @@
- AC_MSG_CHECKING([Whether to write dependencies into .pc files])
- case $enable_explicit_deps in
- auto)
-- deplib_check_method=`(./libtool --config; echo eval echo \\$deplib_check_method) | sh`
-+ deplib_check_method=`($host_alias-libtool --config; echo eval echo \\$deplib_check_method) | sh`
- if test "X$deplib_check_method" = Xnone || test "x$enable_static" = xyes ; then
- enable_explicit_deps=yes
- else
-@@ -688,7 +688,7 @@
- dnl Now we check to see if our libtool supports shared lib deps
- dnl (in a rather ugly way even)
- if $dynworks; then
-- pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
-+ pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} $host_alias-libtool --config"
- pixbuf_deplibs_check=`$pixbuf_libtool_config | \
- grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
- sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
-@@ -1512,7 +1512,7 @@
- #
- # We are using gmodule-no-export now, but I'm leaving the stripping
- # code in place for now, since pango and atk still require gmodule.
--export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
-+export_dynamic=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
- if test -n "$export_dynamic"; then
- GDK_PIXBUF_DEP_LIBS=`echo $GDK_PIXBUF_DEP_LIBS | sed -e "s/$export_dynamic//"`
- GDK_PIXBUF_XLIB_DEP_LIBS=`echo $GDK_PIXBUF_XLIB_DEP_LIBS | sed -e "s/$export_dynamic//"`
diff --git a/packages/gtk+/gtk+-2.8.9/menu-deactivate.patch b/packages/gtk+/gtk+-2.8.9/menu-deactivate.patch
deleted file mode 100644
index 29e665fbf3..0000000000
--- a/packages/gtk+/gtk+-2.8.9/menu-deactivate.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- gtk+-2.4.4/gtk/gtkmenushell.c.old Thu Aug 26 23:45:28 2004
-+++ gtk+-2.4.4/gtk/gtkmenushell.c Fri Aug 27 00:13:33 2004
-@@ -37,7 +37,7 @@
- #include "gtktearoffmenuitem.h"
- #include "gtkwindow.h"
-
--#define MENU_SHELL_TIMEOUT 500
-+#define MENU_SHELL_TIMEOUT 2000
-
- enum {
- DEACTIVATE,
-@@ -156,6 +156,7 @@
- static GtkContainerClass *parent_class = NULL;
- static guint menu_shell_signals[LAST_SIGNAL] = { 0 };
-
-+static int last_crossing_time;
-
- GType
- gtk_menu_shell_get_type (void)
-@@ -418,6 +419,7 @@
- gtk_grab_add (GTK_WIDGET (menu_shell));
- menu_shell->have_grab = TRUE;
- menu_shell->active = TRUE;
-+ last_crossing_time = 0;
- }
- }
-
-@@ -545,6 +547,13 @@
- menu_shell->activate_time = 0;
- deactivate = FALSE;
- }
-+
-+ if (last_crossing_time != 0
-+ && ((event->time - last_crossing_time) < 500))
-+ {
-+ last_crossing_time = 0;
-+ deactivate = FALSE;
-+ }
-
- if (deactivate)
- {
-@@ -597,6 +606,8 @@
- if (menu_shell->active)
- {
- menu_item = gtk_get_event_widget ((GdkEvent*) event);
-+
-+ last_crossing_time = event->time;
-
- if (!menu_item ||
- (GTK_IS_MENU_ITEM (menu_item) &&
diff --git a/packages/gtk+/gtk+-2.8.9/no-demos.patch b/packages/gtk+/gtk+-2.8.9/no-demos.patch
deleted file mode 100644
index 0145067ad5..0000000000
--- a/packages/gtk+/gtk+-2.8.9/no-demos.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- gtk+-2.8.6/Makefile.am.orig 2005-12-07 21:30:56 +0100
-+++ gtk+-2.8.6/Makefile.am 2005-12-07 21:31:10 +0100
-@@ -1,6 +1,6 @@
- ## Makefile.am for GTK+
-
--SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests perf contrib
-+SRC_SUBDIRS = gdk-pixbuf gdk gtk modules tests perf contrib
- SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros
-
- # require automake 1.4
diff --git a/packages/gtk+/gtk+-2.8.9/no-xwc.patch b/packages/gtk+/gtk+-2.8.9/no-xwc.patch
deleted file mode 100644
index affb4a303e..0000000000
--- a/packages/gtk+/gtk+-2.8.9/no-xwc.patch
+++ /dev/null
@@ -1,151 +0,0 @@
-diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c
---- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c 2004-11-30 14:57:14 +00:00
-+++ gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c 2005-01-02 15:38:06 +00:00
-@@ -576,12 +576,14 @@
- GDK_GC_GET_XGC (gc), x, y, (XChar2b *) text, text_length / 2);
- }
- }
-+#ifdef HAVE_XWC
- else if (font->type == GDK_FONT_FONTSET)
- {
- XFontSet fontset = (XFontSet) GDK_FONT_XFONT (font);
- XmbDrawString (xdisplay, impl->xid,
- fontset, GDK_GC_GET_XGC (gc), x, y, text, text_length);
- }
-+#endif
- else
- g_error("undefined font type\n");
- }
-@@ -613,6 +615,7 @@
- GDK_GC_GET_XGC (gc), x, y, text_8bit, text_length);
- g_free (text_8bit);
- }
-+#ifdef HAVE_XWC
- else if (font->type == GDK_FONT_FONTSET)
- {
- if (sizeof(GdkWChar) == sizeof(wchar_t))
-@@ -633,6 +636,7 @@
- g_free (text_wchar);
- }
- }
-+#endif
- else
- g_error("undefined font type\n");
- }
-diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/gdkfont-x11.c
---- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c 2004-08-26 01:23:46 +01:00
-+++ gtk+-2.6.0/gdk/x11/gdkfont-x11.c 2005-01-02 15:45:39 +00:00
-@@ -525,10 +525,12 @@
- width = XTextWidth16 (xfont, (XChar2b *) text, text_length / 2);
- }
- break;
-+#ifdef HAVE_XWC
- case GDK_FONT_FONTSET:
- fontset = (XFontSet) private->xfont;
- width = XmbTextEscapement (fontset, text, text_length);
- break;
-+#endif
- default:
- width = 0;
- }
-@@ -578,6 +580,7 @@
- width = 0;
- }
- break;
-+#ifdef HAVE_XWC
- case GDK_FONT_FONTSET:
- if (sizeof(GdkWChar) == sizeof(wchar_t))
- {
-@@ -595,6 +598,7 @@
- g_free (text_wchar);
- }
- break;
-+#endif
- default:
- width = 0;
- }
-@@ -667,6 +671,7 @@
- if (descent)
- *descent = overall.descent;
- break;
-+#ifdef HAVE_XWC
- case GDK_FONT_FONTSET:
- fontset = (XFontSet) private->xfont;
- XmbTextExtents (fontset, text, text_length, &ink, &logical);
-@@ -681,6 +686,7 @@
- if (descent)
- *descent = ink.y + ink.height;
- break;
-+#endif
- }
-
- }
-@@ -753,6 +759,7 @@
- *descent = overall.descent;
- break;
- }
-+#ifdef HAVE_XWC
- case GDK_FONT_FONTSET:
- fontset = (XFontSet) private->xfont;
-
-@@ -780,6 +787,7 @@
- if (descent)
- *descent = ink.y + ink.height;
- break;
-+#endif
- }
-
- }
-diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c gtk+-2.6.0/gdk/x11/gdkim-x11.c
---- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c 2004-11-17 00:55:10 +00:00
-+++ gtk+-2.6.0/gdk/x11/gdkim-x11.c 2005-01-02 15:42:04 +00:00
-@@ -48,6 +48,7 @@
- void
- _gdk_x11_initialize_locale (void)
- {
-+#ifdef HAVE_XWC
- wchar_t result;
- gchar *current_locale;
- static char *last_locale = NULL;
-@@ -93,7 +94,8 @@
- GDK_NOTE (XIM,
- g_message ("%s multi-byte string functions.",
- gdk_use_mb ? "Using" : "Not using"));
--
-+#endif
-+
- return;
- }
-
-@@ -136,6 +138,7 @@
- {
- gchar *mbstr;
-
-+#ifdef HAVE_XWC
- if (gdk_use_mb)
- {
- GdkDisplay *display = find_a_display ();
-@@ -178,6 +181,7 @@
- XFree (tpr.value);
- }
- else
-+#endif
- {
- gint length = 0;
- gint i;
-@@ -210,6 +214,7 @@
- gint
- gdk_mbstowcs (GdkWChar *dest, const gchar *src, gint dest_max)
- {
-+#ifdef HAVE_XWC
- if (gdk_use_mb)
- {
- GdkDisplay *display = find_a_display ();
-@@ -242,6 +247,7 @@
- return len_cpy;
- }
- else
-+#endif
- {
- gint i;
-
diff --git a/packages/gtk+/gtk+-2.8.9/scroll-timings.patch b/packages/gtk+/gtk+-2.8.9/scroll-timings.patch
deleted file mode 100644
index a38b21dcc2..0000000000
--- a/packages/gtk+/gtk+-2.8.9/scroll-timings.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- gtk+-2.4.4/gtk/gtkrange.c~ 2004-08-23 01:50:22.000000000 +0100
-+++ gtk+-2.4.4/gtk/gtkrange.c 2004-08-27 15:48:49.000000000 +0100
-@@ -35,9 +35,9 @@
- #include "gtkintl.h"
- #include "gtkscrollbar.h"
-
--#define SCROLL_INITIAL_DELAY 250 /* must hold button this long before ... */
--#define SCROLL_LATER_DELAY 100 /* ... it starts repeating at this rate */
--#define UPDATE_DELAY 300 /* Delay for queued update */
-+#define SCROLL_INITIAL_DELAY 500 /* must hold button this long before ... */
-+#define SCROLL_LATER_DELAY 200 /* ... it starts repeating at this rate */
-+#define UPDATE_DELAY 1000 /* Delay for queued update */
-
- enum {
- PROP_0,
diff --git a/packages/gtk+/gtk+-2.8.9/single-click.patch b/packages/gtk+/gtk+-2.8.9/single-click.patch
deleted file mode 100644
index 1bf0db12a8..0000000000
--- a/packages/gtk+/gtk+-2.8.9/single-click.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- gtk+-2.8.6/gtk/gtkfilesel.c.orig 2005-12-07 21:13:33 +0100
-+++ gtk+-2.8.6/gtk/gtkfilesel.c 2005-12-07 21:14:56 +0100
-@@ -2461,6 +2461,33 @@
- if (fs->last_selected != NULL)
- g_free (fs->last_selected);
-
-+ // Single-click directory entry
-+ if (new_names->len == 1)
-+ {
-+ GtkTreeView *tree_view;
-+ GtkTreeModel *model;
-+ GtkTreePath *path;
-+ GtkTreeIter iter;
-+ gboolean is_file;
-+
-+ tree_view = gtk_tree_selection_get_tree_view (selection);
-+
-+ if (gtk_tree_selection_get_selected (selection, &model, &iter))
-+ {
-+ path = gtk_tree_model_get_path (model, &iter);
-+ gtk_tree_model_get (model, &iter, ISFILE_COLUMN, &is_file, -1);
-+
-+ if (!is_file)
-+ {
-+ gtk_file_selection_dir_activate (tree_view, path,
-+ gtk_tree_view_get_column (tree_view, DIR_COLUMN),
-+ user_data);
-+ }
-+
-+ gtk_tree_path_free (path);
-+ }
-+ }
-+
- fs->last_selected = g_strdup (g_ptr_array_index (new_names, index));
- filename = get_real_filename (fs->last_selected, FALSE);
-
diff --git a/packages/gtk+/gtk+-2.8.9/small-gtkfilesel.patch b/packages/gtk+/gtk+-2.8.9/small-gtkfilesel.patch
deleted file mode 100644
index 20bf4cf366..0000000000
--- a/packages/gtk+/gtk+-2.8.9/small-gtkfilesel.patch
+++ /dev/null
@@ -1,267 +0,0 @@
-diff -urNd ../gtk+-2.4.4-r5/gtk+-2.4.4/gtk/gtkfilesel.c gtk+-2.4.4/gtk/gtkfilesel.c
---- ../gtk+-2.4.4-r5/gtk+-2.4.4/gtk/gtkfilesel.c 2004-07-10 05:02:10.000000000 +0100
-+++ gtk+-2.4.4/gtk/gtkfilesel.c 2004-09-13 13:40:09.000000000 +0100
-@@ -68,6 +68,7 @@
- #include "gtkprivate.h"
- #include "gtkscrolledwindow.h"
- #include "gtkstock.h"
-+#include "gtksignal.h"
- #include "gtktreeselection.h"
- #include "gtktreeview.h"
- #include "gtkvbox.h"
-@@ -77,6 +78,7 @@
- #include "gtkmessagedialog.h"
- #include "gtkdnd.h"
- #include "gtkeventbox.h"
-+#include "gtkimage.h"
-
- #undef GTK_DISABLE_DEPRECATED
- #include "gtkoptionmenu.h"
-@@ -245,7 +247,8 @@
- };
-
- enum {
-- DIR_COLUMN
-+ DIR_COLUMN,
-+ ISFILE_COLUMN
- };
-
- enum {
-@@ -400,6 +403,12 @@
- GtkTreePath *path,
- GtkTreeViewColumn *column,
- gpointer user_data);
-+
-+static void gtk_file_selection_activate (GtkTreeView *tree_view,
-+ GtkTreePath *path,
-+ GtkTreeViewColumn *column,
-+ gpointer user_data);
-+
- static void gtk_file_selection_file_changed (GtkTreeSelection *selection,
- gpointer user_data);
- static void gtk_file_selection_dir_activate (GtkTreeView *tree_view,
-@@ -419,6 +428,7 @@
- static void gtk_file_selection_create_dir (GtkWidget *widget, gpointer data);
- static void gtk_file_selection_delete_file (GtkWidget *widget, gpointer data);
- static void gtk_file_selection_rename_file (GtkWidget *widget, gpointer data);
-+static void gtk_file_selection_style_set (GtkWidget *widget, GtkStyle *prev_style);
-
- static void free_selected_names (GPtrArray *names);
-
-@@ -578,6 +588,23 @@
- G_PARAM_WRITABLE));
- object_class->destroy = gtk_file_selection_destroy;
- widget_class->map = gtk_file_selection_map;
-+ widget_class->style_set = gtk_file_selection_style_set;
-+
-+ gtk_widget_class_install_style_property (widget_class,
-+ g_param_spec_boolean ("show_fileops_default",
-+ _("Show fileop buttons by default"),
-+ _("Whether file operation buttons are shown by default"),
-+ TRUE,
-+ G_PARAM_READABLE));
-+
-+ gtk_widget_class_install_style_property (widget_class,
-+ g_param_spec_int ("border_width",
-+ _("Border width"),
-+ _("Width of border around the main dialog area"),
-+ 0,
-+ G_MAXINT,
-+ 10,
-+ G_PARAM_READABLE));
- }
-
- static void gtk_file_selection_set_property (GObject *object,
-@@ -649,7 +676,29 @@
- gtk_widget_grab_default (widget);
- return FALSE;
- }
--
-+
-+static void
-+gtk_file_selection_style_set (GtkWidget *filesel,
-+ GtkStyle *prev_style)
-+{
-+ gboolean show_fileops;
-+ gint border_width;
-+
-+ gtk_widget_style_get (filesel,
-+ "show_fileops_default",
-+ &show_fileops,
-+ "border_width",
-+ &border_width,
-+ NULL);
-+
-+ gtk_container_set_border_width (GTK_CONTAINER (filesel), border_width);
-+
-+ if (show_fileops)
-+ gtk_file_selection_show_fileop_buttons (GTK_FILE_SELECTION (filesel));
-+ else
-+ gtk_file_selection_hide_fileop_buttons (GTK_FILE_SELECTION (filesel));
-+}
-+
- static void
- gtk_file_selection_init (GtkFileSelection *filesel)
- {
-@@ -674,17 +723,15 @@
-
- /* The dialog-sized vertical box */
- filesel->main_vbox = dialog->vbox;
-- gtk_container_set_border_width (GTK_CONTAINER (filesel), 10);
-
- /* The horizontal box containing create, rename etc. buttons */
- filesel->button_area = gtk_hbutton_box_new ();
- gtk_button_box_set_layout (GTK_BUTTON_BOX (filesel->button_area), GTK_BUTTONBOX_START);
-- gtk_box_set_spacing (GTK_BOX (filesel->button_area), 0);
- gtk_box_pack_start (GTK_BOX (filesel->main_vbox), filesel->button_area,
- FALSE, FALSE, 0);
- gtk_widget_show (filesel->button_area);
-
-- gtk_file_selection_show_fileop_buttons (filesel);
-+ gtk_file_selection_style_set (GTK_WIDGET (filesel), NULL);
-
- /* hbox for pulldown menu */
- pulldown_hbox = gtk_hbox_new (TRUE, 5);
-@@ -723,25 +770,32 @@
-
- /* The directories list */
-
-- model = gtk_list_store_new (1, G_TYPE_STRING);
-+ model = gtk_list_store_new (2, G_TYPE_STRING, G_TYPE_BOOLEAN); /* MA */
- filesel->dir_list = gtk_tree_view_new_with_model (GTK_TREE_MODEL (model));
- g_object_unref (model);
-
-- column = gtk_tree_view_column_new_with_attributes (_("Folders"),
-+ column = gtk_tree_view_column_new_with_attributes (/*_("Folders")*/ NULL,
- gtk_cell_renderer_text_new (),
- "text", DIR_COLUMN,
- NULL);
- label = gtk_label_new_with_mnemonic (_("Fol_ders"));
- gtk_label_set_mnemonic_widget (GTK_LABEL (label), filesel->dir_list);
- gtk_widget_show (label);
-- gtk_tree_view_column_set_widget (column, label);
-+
-+ /* gtk_tree_view_column_set_widget (column, label); */
-+ gtk_tree_view_set_headers_visible (GTK_TREE_VIEW (filesel->dir_list), FALSE);
-+
- gtk_tree_view_column_set_sizing (column, GTK_TREE_VIEW_COLUMN_AUTOSIZE);
- gtk_tree_view_append_column (GTK_TREE_VIEW (filesel->dir_list), column);
-
- gtk_widget_set_size_request (filesel->dir_list,
- DIR_LIST_WIDTH, DIR_LIST_HEIGHT);
- g_signal_connect (filesel->dir_list, "row_activated",
-- G_CALLBACK (gtk_file_selection_dir_activate), filesel);
-+ G_CALLBACK (gtk_file_selection_activate), filesel);
-+
-+ g_signal_connect (gtk_tree_view_get_selection (GTK_TREE_VIEW (filesel->dir_list)), "changed",
-+ G_CALLBACK (gtk_file_selection_file_changed), filesel);
-+
-
- /* gtk_clist_column_titles_passive (GTK_CLIST (filesel->dir_list)); */
-
-@@ -758,41 +812,6 @@
- gtk_widget_show (filesel->dir_list);
- gtk_widget_show (scrolled_win);
-
-- /* The files list */
-- model = gtk_list_store_new (1, G_TYPE_STRING);
-- filesel->file_list = gtk_tree_view_new_with_model (GTK_TREE_MODEL (model));
-- g_object_unref (model);
--
-- column = gtk_tree_view_column_new_with_attributes (_("Files"),
-- gtk_cell_renderer_text_new (),
-- "text", FILE_COLUMN,
-- NULL);
-- label = gtk_label_new_with_mnemonic (_("_Files"));
-- gtk_label_set_mnemonic_widget (GTK_LABEL (label), filesel->file_list);
-- gtk_widget_show (label);
-- gtk_tree_view_column_set_widget (column, label);
-- gtk_tree_view_column_set_sizing (column, GTK_TREE_VIEW_COLUMN_AUTOSIZE);
-- gtk_tree_view_append_column (GTK_TREE_VIEW (filesel->file_list), column);
--
-- gtk_widget_set_size_request (filesel->file_list,
-- FILE_LIST_WIDTH, FILE_LIST_HEIGHT);
-- g_signal_connect (filesel->file_list, "row_activated",
-- G_CALLBACK (gtk_file_selection_file_activate), filesel);
-- g_signal_connect (gtk_tree_view_get_selection (GTK_TREE_VIEW (filesel->file_list)), "changed",
-- G_CALLBACK (gtk_file_selection_file_changed), filesel);
--
-- /* gtk_clist_column_titles_passive (GTK_CLIST (filesel->file_list)); */
--
-- scrolled_win = gtk_scrolled_window_new (NULL, NULL);
-- gtk_scrolled_window_set_shadow_type (GTK_SCROLLED_WINDOW (scrolled_win), GTK_SHADOW_IN);
-- gtk_container_add (GTK_CONTAINER (scrolled_win), filesel->file_list);
-- gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (scrolled_win),
-- GTK_POLICY_AUTOMATIC, GTK_POLICY_ALWAYS);
-- gtk_container_set_border_width (GTK_CONTAINER (scrolled_win), 0);
-- gtk_container_add (GTK_CONTAINER (list_container), scrolled_win);
-- gtk_widget_show (filesel->file_list);
-- gtk_widget_show (scrolled_win);
--
- /* action area for packing buttons into. */
- filesel->action_area = gtk_hbox_new (TRUE, 0);
- gtk_box_pack_start (GTK_BOX (filesel->main_vbox), filesel->action_area,
-@@ -2008,6 +2027,23 @@
- }
-
- static void
-+gtk_file_selection_activate (GtkTreeView *tree_view,
-+ GtkTreePath *path,
-+ GtkTreeViewColumn *column,
-+ gpointer user_data)
-+{
-+ GtkTreeModel *model = gtk_tree_view_get_model (tree_view);
-+ GtkTreeIter iter;
-+ gboolean is_file;
-+
-+ gtk_tree_model_get_iter (model, &iter, path);
-+ gtk_tree_model_get (model, &iter, ISFILE_COLUMN, &is_file, -1);
-+
-+ if (! is_file)
-+ gtk_file_selection_dir_activate (tree_view, path, column, user_data);
-+}
-+
-+static void
- gtk_file_selection_file_activate (GtkTreeView *tree_view,
- GtkTreePath *path,
- GtkTreeViewColumn *column,
-@@ -2103,7 +2139,6 @@
- PossibleCompletion* poss;
- GtkTreeIter iter;
- GtkListStore *dir_model;
-- GtkListStore *file_model;
- gchar* filename;
- gchar* rem_path = rel_path;
- gchar* sel_text;
-@@ -2125,10 +2160,8 @@
- g_assert (cmpl_state->reference_dir);
-
- dir_model = GTK_LIST_STORE (gtk_tree_view_get_model (GTK_TREE_VIEW (fs->dir_list)));
-- file_model = GTK_LIST_STORE (gtk_tree_view_get_model (GTK_TREE_VIEW (fs->file_list)));
-
- gtk_list_store_clear (dir_model);
-- gtk_list_store_clear (file_model);
-
- /* Set the dir list to include ./ and ../ */
- gtk_list_store_append (dir_model, &iter);
-@@ -2150,13 +2183,17 @@
- strcmp (filename, ".." G_DIR_SEPARATOR_S) != 0)
- {
- gtk_list_store_append (dir_model, &iter);
-- gtk_list_store_set (dir_model, &iter, DIR_COLUMN, filename, -1);
-+ gtk_list_store_set (dir_model, &iter,
-+ DIR_COLUMN, filename,
-+ ISFILE_COLUMN, FALSE, -1);
- }
- }
- else
- {
-- gtk_list_store_append (file_model, &iter);
-- gtk_list_store_set (file_model, &iter, DIR_COLUMN, filename, -1);
-+ gtk_list_store_append (dir_model, &iter);
-+ gtk_list_store_set (dir_model, &iter,
-+ DIR_COLUMN, filename,
-+ ISFILE_COLUMN, TRUE, -1);
- }
- }
-
diff --git a/packages/gtk+/gtk+-2.8.9/spinbutton.patch b/packages/gtk+/gtk+-2.8.9/spinbutton.patch
deleted file mode 100644
index 8ad7507af0..0000000000
--- a/packages/gtk+/gtk+-2.8.9/spinbutton.patch
+++ /dev/null
@@ -1,128 +0,0 @@
---- gtk+-2.4.3/gtk/gtkspinbutton.c.old 2004-04-22 14:49:27.000000000 +0100
-+++ gtk+-2.4.3/gtk/gtkspinbutton.c 2004-06-30 21:48:18.000000000 +0100
-@@ -733,7 +733,7 @@
-
- spin = GTK_SPIN_BUTTON (widget);
- arrow_size = spin_button_get_arrow_size (spin);
-- panel_width = arrow_size + 2 * widget->style->xthickness;
-+ panel_width = (2 * arrow_size) + 4 * widget->style->xthickness;
-
- widget->allocation = *allocation;
-
-@@ -866,19 +866,16 @@
- {
- width = spin_button_get_arrow_size (spin_button) + 2 * widget->style->xthickness;
-
-+ y = widget->style->ythickness;
-+ height = widget->requisition.height - (2 * y);
-+
- if (arrow_type == GTK_ARROW_UP)
- {
- x = 0;
-- y = 0;
--
-- height = widget->requisition.height / 2;
- }
- else
- {
-- x = 0;
-- y = widget->requisition.height / 2;
--
-- height = (widget->requisition.height + 1) / 2;
-+ x = width;
- }
-
- if (spin_button_at_limit (spin_button, arrow_type))
-@@ -908,32 +905,17 @@
- shadow_type = GTK_SHADOW_OUT;
- }
- }
--
-+
- gtk_paint_box (widget->style, spin_button->panel,
- state_type, shadow_type,
- NULL, widget,
-- (arrow_type == GTK_ARROW_UP)? "spinbutton_up" : "spinbutton_down",
-+ NULL,
- x, y, width, height);
-
- height = widget->requisition.height;
-
-- if (arrow_type == GTK_ARROW_DOWN)
-- {
-- y = height / 2;
-- height = height - y - 2;
-- }
-- else
-- {
-- y = 2;
-- height = height / 2 - 2;
-- }
--
- width -= 3;
--
-- if (widget && gtk_widget_get_direction (widget) == GTK_TEXT_DIR_RTL)
-- x = 2;
-- else
-- x = 1;
-+ height -= 3;
-
- w = width / 2;
- w -= w % 2 - 1; /* force odd */
-@@ -1108,7 +1090,7 @@
- if (GTK_ENTRY (widget)->editable)
- gtk_spin_button_update (spin);
-
-- if (event->y <= widget->requisition.height / 2)
-+ if (event->x <= (spin_button_get_arrow_size (spin) + widget->style->xthickness))
- {
- if (event->button == 1)
- start_spinning (spin, GTK_ARROW_UP, spin->adjustment->step_increment);
-@@ -1143,44 +1125,11 @@
-
- arrow_size = spin_button_get_arrow_size (spin);
-
-- if (event->button == spin->button)
-- {
-- int click_child = spin->click_child;
-+ gtk_spin_button_stop_spinning (spin);
-
-- gtk_spin_button_stop_spinning (spin);
--
-- if (event->button == 3)
-- {
-- if (event->y >= 0 && event->x >= 0 &&
-- event->y <= widget->requisition.height &&
-- event->x <= arrow_size + 2 * widget->style->xthickness)
-- {
-- if (click_child == GTK_ARROW_UP &&
-- event->y <= widget->requisition.height / 2)
-- {
-- gdouble diff;
--
-- diff = spin->adjustment->upper - spin->adjustment->value;
-- if (diff > EPSILON)
-- gtk_spin_button_real_spin (spin, diff);
-- }
-- else if (click_child == GTK_ARROW_DOWN &&
-- event->y > widget->requisition.height / 2)
-- {
-- gdouble diff;
--
-- diff = spin->adjustment->value - spin->adjustment->lower;
-- if (diff > EPSILON)
-- gtk_spin_button_real_spin (spin, -diff);
-- }
-- }
-- }
-- spin_button_redraw (spin);
-+ spin_button_redraw (spin);
-
-- return TRUE;
-- }
-- else
-- return GTK_WIDGET_CLASS (parent_class)->button_release_event (widget, event);
-+ return TRUE;
- }
-
- static gint