aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-webcore/osb-jscore-0.5.0
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gtk-webcore/osb-jscore-0.5.0')
-rw-r--r--packages/gtk-webcore/osb-jscore-0.5.0/.mtn2git_empty0
-rw-r--r--packages/gtk-webcore/osb-jscore-0.5.0/libm.patch13
-rw-r--r--packages/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch10
3 files changed, 23 insertions, 0 deletions
diff --git a/packages/gtk-webcore/osb-jscore-0.5.0/.mtn2git_empty b/packages/gtk-webcore/osb-jscore-0.5.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gtk-webcore/osb-jscore-0.5.0/.mtn2git_empty
diff --git a/packages/gtk-webcore/osb-jscore-0.5.0/libm.patch b/packages/gtk-webcore/osb-jscore-0.5.0/libm.patch
index e69de29bb2..b0c0cc6af2 100644
--- a/packages/gtk-webcore/osb-jscore-0.5.0/libm.patch
+++ b/packages/gtk-webcore/osb-jscore-0.5.0/libm.patch
@@ -0,0 +1,13 @@
+Index: osb-jscore-0.5.0/configure.in
+===================================================================
+--- osb-jscore-0.5.0.orig/configure.in 2004-10-18 11:39:43.000000000 -0400
++++ osb-jscore-0.5.0/configure.in 2005-02-02 17:36:36.551550088 -0500
+@@ -18,6 +18,8 @@
+ AC_CHECK_HEADERS(string.h strings.h float.h)
+
+
++# isnan & friends generally come from libm, so link to it if its available
++AC_CHECK_LIB(m, sin)
+
+ AC_CHECK_FUNCS(isnan,[
+ AC_DEFINE(HAVE_FUNC_ISNAN,[],[Define to 1 if you have isnan function.])
diff --git a/packages/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch b/packages/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch
index e69de29bb2..42d6ebc9f8 100644
--- a/packages/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch
+++ b/packages/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch
@@ -0,0 +1,10 @@
+--- osb-jscore-0.5.0.orig/kjs/lookup.h 2004-09-23 10:27:54.000000000 +0200
++++ osb-jscore-0.5.0/kjs/lookup.h 2004-10-23 22:09:47.000000000 +0200
+@@ -24,6 +24,7 @@
+ #define _KJSLOOKUP_H_
+
+ #include "identifier.h"
++#include "object.h"
+ #include "value.h"
+ #include <stdio.h>
+