aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap/hostap-utils_0.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hostap/hostap-utils_0.3.2.bb')
-rw-r--r--packages/hostap/hostap-utils_0.3.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/hostap/hostap-utils_0.3.2.bb b/packages/hostap/hostap-utils_0.3.2.bb
index e69de29bb2..49036a7421 100644
--- a/packages/hostap/hostap-utils_0.3.2.bb
+++ b/packages/hostap/hostap-utils_0.3.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV})"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}
+